Zooming audio clips lag

Discussion in 'Live' started by badformat, Nov 1, 2016.

  1. badformat

    badformat Ultrasonic

    Joined:
    Mar 26, 2014
    Messages:
    29
    Likes Received:
    25
    Hi, guys.

    Am i the only person who got this zoom lag on a long audio clips (only on audio, midi is ok)???

    (sorry for quality)

    You can see on the video i'm zooming clips and it starts freezing and even stops at some point, but i'm still scrolling

    As you can see same in the sample view.

    I don't have any issue with audio, dpc latency is ok. It's only visual lag, which really annoying and killing my workflow.

    Tested on 3 Windows system and results is the same. Here is specs:

    My home PC:

    OS: Windows 10
    CPU: Intel Core i5 - 6600k
    MB: Asus Z170-A
    RAM: 8 Gb DDR4
    GPU: NVidia GTX950
    SSD: 500 Gb
    HDD: 7400 RPM 1 TB
    PSU: Corsair cx750m

    My home laptop:

    OS: Windows 8.1
    CPU: Intel Core i5 - 3230M
    MB: Intel HM76 Express
    GPU: NVIDIA GeForce 710M
    RAM: 8 Gb DDR3 2600 Mhz
    HDD: 500 Gb 5400 RPM

    My friend's laptop:

    OS: Windows 8.1
    CPU: Intel Core i3 - 3217U
    MB: Asus P500CA
    RAM: 8GB DDR3 1600 Mhz
    GPU: Intel(R) HD Graphics 4000
    SSD: Kingston SV300S37A120G

    Can someone confirm that have same issue?

    Thanks.
     
  2.  
  3. badformat

    badformat Ultrasonic

    Joined:
    Mar 26, 2014
    Messages:
    29
    Likes Received:
    25
    Anyone? Or here is only Mac guys?
     
  4. Pinkman

    Pinkman Audiosexual

    Joined:
    Apr 22, 2016
    Messages:
    1,394
    Likes Received:
    1,170
    My setup is David compared to your Goliaths and I don't have that visual lag.
    Why are you duplicating your audio tracks like that? I think that's causing it.
    Live has to cache all that audio data.
    After consolidating see if the lag persists if you focus zoom with just the one audio track you consolidated in.

    After consolidating an audio clip just make duplicates of it in the same track and use the extra space to the right to do your slicing or whatnot.
    The extra tracks seem redundant. If you're trying to to apply different effects to each track separately just keep the original and create more audio tracks without any audio clips, add FX as you see fit on each and in the 'Audio From' select the audio track with the original audio clip.
    Better yet, setup Return tracks then enable and use the Sends.
     
    Last edited: Nov 3, 2016
  5. badformat

    badformat Ultrasonic

    Joined:
    Mar 26, 2014
    Messages:
    29
    Likes Received:
    25
    Hi, Pinkman.

    Thanks for your reply.

    Yeah, you're right, there is no sense to dublicate audio tracks like i did it on a video. I've made it just because want to explain my issue clearer.

    I have lags just with one 2 bars audio track (with or without consolidation, no matter), they are not so obvious like with 4 dublicated audio tracks, but still exists. The more audio tracks i have the more lags i see.

    And yes, i think my home system is not so bad to handle this kind of operations in Live.

    I've already tried everything:

    1) Changing Ableton version. (9.1, 9.5, 9.7 same results)
    2) Turn off all usb/midi controllers
    3) Different audio drivers (ASIO for my Scarlett 2i2, ASIO4ALL, MME Realtek)
    4) Lower sample rate and higher buffer size
    5) Making all necessary optimisation for audio on my OS and BIOS setting. (Plus BIOS and all drivers are up to date)
    6) Changing primary GPU to Intel integrated graphics card

    The only way to solve my problem is to enable RAM option on audio clip. Or use Live 8.

    That's why i want to understand is it a software bug or maybe some kind of hardware/software compability problem? The weirdest thing is that i can replicate that issue on 4 different Windows PC.

    By the way 8-10 audio tracks is not too much for a good song.
     
  6. Pinkman

    Pinkman Audiosexual

    Joined:
    Apr 22, 2016
    Messages:
    1,394
    Likes Received:
    1,170
    Are you running the 64-bit version of Live?
     
  7. badformat

    badformat Ultrasonic

    Joined:
    Mar 26, 2014
    Messages:
    29
    Likes Received:
    25
    Yes, of course.
     
  8. Pinkman

    Pinkman Audiosexual

    Joined:
    Apr 22, 2016
    Messages:
    1,394
    Likes Received:
    1,170
    Other than disabling all uneccesary services, anti-virus, network adapters and running something like Process Lasso and prioritizing the Ableton Live process, I'm not sure sure.

    I can get 28 tracks before I get any discernible lag and it's slight.
    I currently only have 4gigs of RAM and just the built-in video card.

    Check Resource Monitor for any spikes while using Live.
    You could also use msconfig to do a selective startup and disable everything and see if the issue persists. Most everything else won't work but at least you can troubleshoot that way. Just remember to return to normal startup.
     
  9. Pinkman

    Pinkman Audiosexual

    Joined:
    Apr 22, 2016
    Messages:
    1,394
    Likes Received:
    1,170
    Or just enable RAM and freeze your tracks.
     
  10. badformat

    badformat Ultrasonic

    Joined:
    Mar 26, 2014
    Messages:
    29
    Likes Received:
    25
    hmmm...I'll try to use Process Lasso and Resource Monitor to check what is going on.

    Thanks.
     
  11. badformat

    badformat Ultrasonic

    Joined:
    Mar 26, 2014
    Messages:
    29
    Likes Received:
    25
    unfortunately, nothing helped. working well only on my hackintosh.
     
  12. Gnib

    Gnib Producer

    Joined:
    Mar 29, 2013
    Messages:
    280
    Likes Received:
    130
    Location:
    Amsterdam
    No such problems here but I noticed that consolidating your clips took quite longer than on my machine (Intel Core i7 920 @ 2.67GHz, 512MB ATI Radeon HD 4800 Series (Sapphire/PCPartner), 16Gb DDR3, so it is all quite old). My projects are on an SSD.

    At the background running multiple processes including my browser.

    I am running Win7.
     
  13. badformat

    badformat Ultrasonic

    Joined:
    Mar 26, 2014
    Messages:
    29
    Likes Received:
    25
    Yeah, that's true. I have an issue with consolidating only with my scarlett 2i2 2nd gen interface. ASIO4ALL consolidating is a lot faster. But changing audio driver is not make a difference for audio clip zooming. I've installed hackintosh on my second drive on same PC few days ago. And everything works like a charm - no zoom lag, fast consolidating.
     
    Last edited: Nov 6, 2016
Loading...
Similar Threads - Zooming audio clips Forum Date
Zooming in the playlist to the sample level in FL Studio FL Studio Jan 2, 2016
(audiothing.net) Wave Box Software News Yesterday at 1:26 PM
(www.sknoteaudio.com) Ch5 Software News Wednesday at 7:40 PM
Audio.Ease.Altiverb.v7.0.5.AU.VST.MacOSX-Adobe-pat ched(HOOK) iLok authorization Mac / Hackintosh Wednesday at 7:29 PM
Eventide Giveaway - EQuivocate EQ by Newfangled Audio Software Wednesday at 12:12 AM
Loading...