Windows 10 limiting gigabit connection to 100Mpbs - SOLVED

Discussion in 'PC' started by RMorgan, Nov 20, 2020.

  1. RMorgan

    RMorgan Rock Star

    Joined:
    May 17, 2014
    Messages:
    559
    Likes Received:
    417
    Hi everyone,

    So, this thing is driving me crazy.

    -I've got a 300mbps internet.

    -My network adapter is gigabit capable.

    -The ISP router to which I'm connected via a perfectly good cable is also gigabite capable.

    However, apparently randomly, Windows 10 limits my Gigabite connection to 100mbps.

    Then, after running some commands like ipconfig /flushdns , netsh int ip reset all,netsh winsock reset and stuff like that, my connection goes back to full speed, and my adapter settings go back to 1.0Gbps stats...But this fix only works sometimes, meaning that sometimes I have to repeat these commands and restart the PC a few times to get it fixed.

    Anyway, I've got this old notebook running Ubuntu that I always use for these kinds of tests, and guess what, whenever I connect it to the same main router, it gets gigabit speed instantly, using the same cable.

    So yes, I'm sure it's a Windows 10 issue.

    Things I've tried (literally every possible fix I've found on the internet):

    -Changing cable (it's a short distance anyway, before someones asks, like 2m)

    -Changing adapter advanced settings (Speed & Duplex) from "Auto Negotiation" to "1.0Gbps Full Duplex". Does't work.

    -Uninstalling and reinstalling the network adapter. Sometimes it works, but not for too long.

    -Disabling global autotuning level.

    -Swapped the network adapter with another one from my wife's computer. Didn't work.

    -Tested the same PC using a live Linux CD. Instant Gigabite speeds.

    Could you guys please help me out?

    Thank you,

    R
     
    • Interesting Interesting x 4
    • List
  2.  
  3. boogiewoogie

    boogiewoogie Producer

    Joined:
    Sep 15, 2012
    Messages:
    389
    Likes Received:
    131
    Did you to install the latest driver manually from the manucfacturer of the chip? That sometimes helps, example direct from Realtek if it is Realtek etc.
     
  4. bigboobs

    bigboobs Ultrasonic

    Joined:
    Oct 10, 2011
    Messages:
    287
    Likes Received:
    31
    Check energy saving options for network adapter and disable it.
     
  5. Xupito

    Xupito Audiosexual

    Joined:
    Jan 21, 2012
    Messages:
    4,528
    Likes Received:
    2,498
    Location:
    Europe
    It should be related to the driver as said above.
    Something seems to change your network settings. Perhaps some wifi optimizer?
     
  6. playtime

    playtime Platinum Record

    Joined:
    Sep 28, 2016
    Messages:
    319
    Likes Received:
    202
  7. SineWave

    SineWave Audiosexual

    Joined:
    Sep 4, 2011
    Messages:
    3,313
    Likes Received:
    2,408
    Location:
    Where the sun doesn't shine.
    I see you've done everything I would, so I don't know what else I could tell you to possibly remedy it. Sorry. :( It seems to be one more quirk in the long list of W10 quirks. Adding it to the list... can you please tell us what version of Windows 10 we should NOT use?
     
  8. realitybytez

    realitybytez Rock Star

    Joined:
    May 29, 2013
    Messages:
    1,084
    Likes Received:
    439
    any
     
  9. jaime varsaa

    jaime varsaa Newbie

    Joined:
    Mar 28, 2016
    Messages:
    3
    Likes Received:
    2
    Try this: Control panel/network and internet/networks connections...see your ethernet adapter...now properties/TCP/Ipv4/configure/Advanced...look for "speed & duplex"...finally choose 1.0Gbps Full Duplex....or "auto negotiation".
    Hope this was helpful.
     
  10. Alpha0ne

    Alpha0ne Producer

    Joined:
    Jan 26, 2012
    Messages:
    596
    Likes Received:
    117

    No Autonegtiation. This does not work correctly. Choose 1.0 Gbps Full duplex.
     
  11. SineWave

    SineWave Audiosexual

    Joined:
    Sep 4, 2011
    Messages:
    3,313
    Likes Received:
    2,408
    Location:
    Where the sun doesn't shine.
    That's what I would suggest, too, but he's tried that already and it didn't work. W10 is just a mess.
     
  12. tzzsmk

    tzzsmk Audiosexual

    Joined:
    Sep 13, 2016
    Messages:
    1,380
    Likes Received:
    799
    Location:
    Heart of Europe
    try different cable, maybe there is a loose contact which triggers NIC driver into 100Mbit mode
    :chilling:
     
  13. Pipotron3000

    Pipotron3000 Audiosexual

    Joined:
    Mar 13, 2013
    Messages:
    1,082
    Likes Received:
    500
  14. jaime varsaa

    jaime varsaa Newbie

    Joined:
    Mar 28, 2016
    Messages:
    3
    Likes Received:
    2
    Don't blame W10 ....is not a mess, Here it works fine and flawlessly :)
     
  15. Polomo

    Polomo Audiosexual

    Joined:
    Oct 30, 2019
    Messages:
    584
    Likes Received:
    557
    Interesting,

    after all this, my tips was on some malware.

    Back-up everything and install Windows clean again.

    And for all others, learn to read properly, please. :suicide:

    -
    -
    -
     
  16. bigboobs

    bigboobs Ultrasonic

    Joined:
    Oct 10, 2011
    Messages:
    287
    Likes Received:
    31
    It's the driver and/or energy settings, nothing else.
    If Ubuntu is running on the same machine with same cable and no problems at all getting 1g, it's the setting.

    It's _not_ Win10 itself, it's config and/or driver.
    I have ftth @1g here on Win10 pro and it runs perfectly smooth w/o any kinda problems.
     
  17. RMorgan

    RMorgan Rock Star

    Joined:
    May 17, 2014
    Messages:
    559
    Likes Received:
    417
    Hi everyone, running DriverPack Solution apparently solved the issue (so far).

    I've tried other driver updating programs before, so apparently all my drivers were up to date, but this one is really good because let's you choose between downloading the newest drivers or the most stable ones.

    I went with the stable versions, updated a lot of stuff, and so far so good.

    Thanks everyone for the help. I really appreciate it.
     
    • Like Like x 2
    • Useful Useful x 2
    • Interesting Interesting x 1
    • List
  18. Xupito

    Xupito Audiosexual

    Joined:
    Jan 21, 2012
    Messages:
    4,528
    Likes Received:
    2,498
    Location:
    Europe
    One of these things you know is gonna happen :rofl::rofl:
     
Loading...
Loading...