Waves v12 Installation on Big Sur (11.5.2)

Discussion in 'Mac / Hackintosh' started by kuth7, Aug 28, 2021.

  1. kuth7

    kuth7 Newbie

    Joined:
    Jul 7, 2019
    Messages:
    8
    Likes Received:
    2
    hi! a newbie here... m1 Mac

    So, according to the instruction text, I need to replace the "WavesLicenseEngine.bundle" in Library/Application Support/Waves/Modules folder. However that "Waves" folder does not exist in Library/Application Support. There are only Waves Central and Waves Audio folders.

    I'm wondering what am I doing wrong... Could a friend explain how to install Waves in the first place?

    (I've tried offline installation on Waves Central but they were blind shots..)

    Thanks in advance..


    INSTRUCTION TEXT

    "Waves Complete Patched + R2R KeyGen Release

    Install Waves.
    Replace "WavesLicenseEngine.bundle" in
    /Library/Application Support/Waves/Modules/

    Run R2R KeyGen on Windows.
    Input Device ID to the keygen.
    You can find the Devices and their ID at Licenses tab in WavesCentral.
    Generate *.wle license.
    Copy *.wle license to

    [Computer License]
    /Library/Application Support/Waves/Licenses/

    [Removable Media License]
    (Device)/Waves/Licenses/


    NOTE: Old license file made by R2R KeyGen or HEXWARS KeyGen will crash.


    Thanks R2R for updating the keygen for RETSU!

    TEAM RETSU"
     
  2.  
  3. Jim Bob

    Jim Bob Ultrasonic

    Joined:
    Jul 14, 2015
    Messages:
    104
    Likes Received:
    20
    The Waves license should be an installer. It's a .pkg file.
    Double click it and it will install. Restart and go to Applications/Waves/WaveShells V12 open and the first app in the list Waves AU Reg Utility.app click that and it will scan your Waves plugs and authorize click OK.
    If this doesn't solve it PM me and I'll walk you through it.
     
  4. Tevor

    Tevor Newbie

    Joined:
    Sep 7, 2021
    Messages:
    3
    Likes Received:
    1
    I have exactly this problem, I've been trying for days and it's driving me mad! Did you find a solution?
     
  5. BigM

    BigM Ultrasonic

    Joined:
    May 21, 2021
    Messages:
    164
    Likes Received:
    38
    Location:
    Heaven Of Warez
    Working Perfectly on M1 no issues here.
     
  6. BigM

    BigM Ultrasonic

    Joined:
    May 21, 2021
    Messages:
    164
    Likes Received:
    38
    Location:
    Heaven Of Warez
    Make sure you follow instructions properly,

    first clean up previous installation files in following locations:

    Macintosh HD / Application > Waves
    Macintosh HD / [Users] / Shared > Waves

    then Go to ~/Library/ (using finder go to option)

    preferences > Waves preferences
    Logs > Waves Audio
    Caches > Waves
    Caches > Waves Audio
    Application support > Waves Audio

    then Go to /Library/ (this is unhidden path not exactly the same)

    Application support > Waves

    after cleaning all above folders,

    1.install waves central.
    2.select offline installation and browse for downloaded content.
    3.select products you need to install and install.
    4.after installation is complete replace "WavesLicenseEngine.bundle" in /Library/Application Support/Waves/Modules/ (this is not a package just replace the exact file)
    5.run R2R keygen on a windows computer or VM.
    6.type your device id (you can find it on waves central licenses tab) and generate license.
    7.copy license file to /Library/Application Support/Waves/Licenses/
    8.Restart computer and open your DAW.

    if you did these things correctly it should work perfectly.

    MAKE SURE YOU USE Waves.Complete.v2021.07.21.MacOSX.Incl.Patched.and.Keygen-RET
     
    Last edited: Sep 7, 2021
    • Like Like x 2
    • Agree Agree x 1
    • List
  7. clone

    clone Platinum Record

    Joined:
    Feb 5, 2021
    Messages:
    627
    Likes Received:
    236
    keep in mind, sometimes you will encounter a "folder not found" error in an installer. sometimes manually creating the folders is all you need to do. worst case scenario, you end up with some blank folders to delete.
     
  8. Tevor

    Tevor Newbie

    Joined:
    Sep 7, 2021
    Messages:
    3
    Likes Received:
    1
    Thanks for your clear replies, I really appreciate you taking the time. That is the process I'd been following so just in case I was missing something (or was just being incredibly stupid), today I've wiped my drive and done a clean install of the OS so there couldn't be any conflicts with anything previously installed. Then the very first thing I did was install Waves Central, offline installation, choosing the products I wanted.

    I still have the same issue.

    The install has created the folders:

    Library/Application Support/Waves Central
    Library/Application Support/Waves Audio

    But there's no: Library/Application Support/Waves

    That folder just hasn't been created, so there's no "WavesLicenseEngine.bundle" anywhere for me to replace.

    I can't think of anything else to try :dunno:
     
  9. BigM

    BigM Ultrasonic

    Joined:
    May 21, 2021
    Messages:
    164
    Likes Received:
    38
    Location:
    Heaven Of Warez
    if you just installed plugins there must be a folder, check if you have plugins in your components or vst folder.

    there must be a waves folder here:

    Go to Folder: /Library/Application Support/Waves/Modules/

    you are talking about the hidden library folder not the generic one. ~/Library/ is hidden one it contains the folders you mentioned
    /Library/ is the one you need to go.

    just right click on the finder icon on dock. select go to folder option. type /Library/ there. press go.
    then go to the application support folder.there must be a waves one.
     
  10. Tevor

    Tevor Newbie

    Joined:
    Sep 7, 2021
    Messages:
    3
    Likes Received:
    1
    You're an absolute legend! It was as simple as that. I'm new to Mac and had no idea the were two Library folders. All working fine now. Thanks so much!
     
  11. kuth7

    kuth7 Newbie

    Joined:
    Jul 7, 2019
    Messages:
    8
    Likes Received:
    2
    Wow! So good to see it is solved for Tevor.

    BUT, now I cannot open Waves Central at all. This permission issue came up. System Prompt for me to Allow never comes up...

    Cleaned all things related to Waves, Uninstalled, re-installed nothing worked... Any Clue? Big Sur is giving me physical pain..
     

    Attached Files:

  12. BigM

    BigM Ultrasonic

    Joined:
    May 21, 2021
    Messages:
    164
    Likes Received:
    38
    Location:
    Heaven Of Warez
    Give full disk access to waves central.

    1. Go to system preferences > privacy & Security > Privacy Tab
    2.Click on the lock item in bottom left and enter password.
    3.Click on Full Disk Access folder and tick waves central.

    Done.

    If it didn't work try reinstalling central, but make sure to give access to waves central on first start.
    by typing password.
     
  13. kuth7

    kuth7 Newbie

    Joined:
    Jul 7, 2019
    Messages:
    8
    Likes Received:
    2
    Thanks for the reply mate!
    Already tried all of those.. I've also contacted Waves Support, they said that it could be M1 Silicon related issue and there's not much to do...

    It looks like dead end to me :(
     
  14. BigM

    BigM Ultrasonic

    Joined:
    May 21, 2021
    Messages:
    164
    Likes Received:
    38
    Location:
    Heaven Of Warez
    There are no any issues with apple silicon. My installation process went smoothly.

    You can try using a new admin account as a final solution rather than a clean install.
     
  15. BigM

    BigM Ultrasonic

    Joined:
    May 21, 2021
    Messages:
    164
    Likes Received:
    38
    Location:
    Heaven Of Warez
    But it seems like you dismissed something during installation.

    But as i mentioned early in this thread try a clean install delete all older folders. Try a fresh install and make sure to give permission by typing your password first time. It's crucial.
     
  16. kuth7

    kuth7 Newbie

    Joined:
    Jul 7, 2019
    Messages:
    8
    Likes Received:
    2
    I've deleted files as you mentioned earlier. Did not ask permission & password. It still doesn't... I'll see what I can do, let me try more :)
     
  17. BigM

    BigM Ultrasonic

    Joined:
    May 21, 2021
    Messages:
    164
    Likes Received:
    38
    Location:
    Heaven Of Warez
    Waves mentioned that creating new user account with admin privileges can solve this. Maybe try that.

    Because reinstalling didn't fix the issue for some people.

    After creating a new account reinstall central and make sure you allow them to make changes.

    This is a detailed article about creating a new admin account:

    https://osxdaily.com/2017/07/17/how-create-new-admin-account-mac/
     
    Last edited: Sep 10, 2021
  18. BigM

    BigM Ultrasonic

    Joined:
    May 21, 2021
    Messages:
    164
    Likes Received:
    38
    Location:
    Heaven Of Warez
    If it didn't ask for permission it might be a user account issue. It also can affect other softwares.

    Did you disabled gatekeeper or sip?
    Do you have any antivirus software?

    For me, gatekeeper and sip are both enabled.
    And make sure to update to the latest os version.

    I think the last thing to try is a new admin account.
     
  19. kuth7

    kuth7 Newbie

    Joined:
    Jul 7, 2019
    Messages:
    8
    Likes Received:
    2
    I've tried to clean install -GateKeeper Disabled- did not work. But I'm not sure what sip is? :)

    PS: As far as I remember, I've tried new admin account as well. But without gatekeeper, I'll try again.
     
  20. kuth7

    kuth7 Newbie

    Joined:
    Jul 7, 2019
    Messages:
    8
    Likes Received:
    2
    YES!! New Admin worked this time. So important question is: When I install the crack on new acc, will it be working on the main one? Wanted no question marks here :)
     
  21. BigM

    BigM Ultrasonic

    Joined:
    May 21, 2021
    Messages:
    164
    Likes Received:
    38
    Location:
    Heaven Of Warez
    If your old account has permission issues it won't work and it can cause future issues.if your old files and apps are accessible on new account i recommend deleting the old one use new one.
     
Loading...
Similar Threads - Waves Installation Forum Date
Waves Plugins Help - Not showing up in any DAW after clean installation Software Mar 22, 2021
Waves Complete - Installation Failed |Workaround Software Feb 6, 2021
installation failed waves 11 plugin vr Software Dec 23, 2020
Problem with the installation of Waves Central Software Oct 22, 2020
Waves 12 installation frozen? Software Oct 20, 2020
Loading...