Spectrasonics Omnisphere help needed please!

Discussion in 'Software' started by DLord, Mar 3, 2018.

  1. DLord

    DLord Newbie

    Joined:
    Feb 11, 2018
    Messages:
    2
    Likes Received:
    1
    Before I begin, please let me say sorry for posting another thread on an Omnisphere 2 problem, but I have been unable to find a solution to fix my issue that I am having.

    I have been all over the web for the past 3 weeks trying to dissect this issue. I have been on numerous pages, watching videos, going through comments, going through replies on different forums. I still can't figure this out. I've even been on this website the most because there is a ridiculous amount of posts on this topic.

    But I just wanted to get this out to maybe find a fixing, hoping that I am not bugging anyone. I am to the point where I would pay to get this issue fixed.

    So here's the story:
    I had an older generation Mac Mini from 2010 that I used for the longest time. I have been producing music for about 2 years now and I thought it'd be a cool idea to install a VST for Logic Pro X. I downloaded the cracked version and went through the installation, & it worked GREAT! No problems whatsoever.
    The Mac Mini that I had was super slow and didn't run specific things that I wanted it to run so I decided I was going to go ahead and get a new iMac. So now I have this iMac, that has everything transferred over from the Mini including OMNISPHERE. I did the installation the same way I did it on my older Mac, only difference is that when I went to install the "Step 1" it did not install all the package files, meaning SOUNDS. So I then opened each ISO after it was mounted and created the STEAM folder myself by dragging and dropping each sound and file in one by one, making sure there were no duplicates. After that I just went on moving the STEAM folder where it should be in Application Support & finished up the installation on my newer iMac. Patched everything, installed everything, it was installing the way it did on my older Mac, so I didn't think I'd run into any problems.
    After it was all set and ready to go, I opened up Omnisphere in Logic and the interface pops up fine, shows all the sounds and what not BUT when I go to click on the sounds I get an error. There are 2 errors I receive when trying to load in a sound.
    The first error I get is "ERROR LOADING WAVEFORM" & eventually the first error leads into the next error which is "CANNOT LOAD SOUNDSOURCE "(SOUND)" IN DIRECTORY "CORE LIBRARY". TRY REFRESHING INDEX IN BROWSER". And I am stuck at that.

    Like I said I wanted to say sorry because I know this forum topic is probably getting old now but I am in a desperate need for help. If anyone can do me a favor and help me out with this problem, I would gladly be willing to send over some money to. That is how serious I have been about this problem and trying to fix it!

    PLEASE AND THANK YOU, I APPRECIATE ANY HELP I CAN GET!
     
  2.  
  3. beatroot

    beatroot Producer

    Joined:
    Nov 14, 2012
    Messages:
    313
    Likes Received:
    106
    Location:
    East
    Hi DLord.I found this on a facebook thread.It may or may not help you.
    This is what Adrian and Zane figured out
    1.
    'I FOUND A SOLUTION TO THIS. i went to the STEAM>Omnisphere>Soundsources folder, deleted the zmap.index from that folder and all the other subfolders (all the libraries I have), then I opened Omnisphere in my DAW again, and updated the index (you do that inside the PATH BROWSER, left right corner hit a button with a circle arrow symbol.). It took me around 3 minutes, and now all works perfect again. Hope it works for you as well. I really looked into this, cause I'm not reinstalling 130 gigabytes of soundsources LOL.'

    Ok. so for those who don't know which subfolders he's talking about, Go to the STEAM folder, then KEYSCAPE, then SOUNDSOURCES, FACTORY, KEYSCAPE LIBRARY and delete the zmap.index file. Do the same for the zmap.index file in STEAM>KEYSCAPE>SOUNDSOURCES>USER. Restart your DAW and load Omnisphere and you should be fine. Thanks to Adrian

    2.
    Zane Kash i figured it out. every time i tried to load a sound i kept getting "cannot load sound source in core library z map corrupted or missing" ....so basically what you have to do is: Make sure to make a copy of the original download JUST TO BE SAFE !.. put it away some where else on the external just so u can have it in case u fuck this process up .... (NOW DO THE FOLLOWING WITH THE COPY DOWNLOAD ) unrar all 8 archived discs,.. now you sholuld have 8 folders....label each folder STEAM 1 -- STEAM 8 (steam1....steam2 ... steam3 ... etc) ok now keep this window open with all the steam (1-8) folders in it . open a second tab and find the location of this same exact folder ..so now you should have two seperate windows with steam folders 1-8 in each (side by side)on the right window open STEAM 1 > OMNISPHERE > SOUNDSOURCES >FACTORY > CORE LIBRARY ...leave this open ! Now go to the left window open steam 2 all The way to core library...open human voices and drag the data base file to to human voices folder on the right ...now drag the sfx and noise AND the textures folder (both whole folders) to the right window and drop them under "version"... KOOL ! okay..noww go to steam 3 on left and open the same path all the way to core library..drag composite morphing AND traditional "FOLDERS to the right window and drop it ...now go back to left window to steam 4...open it up til core library ..okay follow the same routine steps until you get to the last steam 8 on the left window : KEEP IN MIND THAT IF THE RIGHT WINDOW ALREADY HAS AN EXISTING FOLDER OF THE ONE YOURE DRAGGING FROM THE LEFT...just take the data base file and the pictures and place them inside the folder that with the same name on the right . for example if theres a "textures folder on the left and a textures folder on the right you dont need the folder...you need the data base file in it . do that for all the STEAMS ON THE LEFT WINDOW . HOPE YALL GET IT..easy process but hella hard to explain..especially trying to type this shit . might have to make a video and post it here .. good luck
     
  4. DLord

    DLord Newbie

    Joined:
    Feb 11, 2018
    Messages:
    2
    Likes Received:
    1


    Hey Beatroot, I appreciate your reply.

    So I went ahead and tried the first solution. I went into the root folder and went to SOUNDSOURCES and removed the zmap. index from both the USER and the FACTORY folders and then went to open Logic and Omnisphere. I didn't really understand the second part of that with the PATH BROWSER. I tired looking it up online where to find the "PATH BROWSER" and I only found PATCH BROWSER, and SOUNDSOURCE BROWSER.

    Also for the 2nd solution, thats what i was trying to explain in the original post was that when I installed the installer of Step 1, I couldn't find the STEAM folder in my APPLICATION SUPPORT folder. So thats exactly what i did, I mounted all the ISO's and created the STEAM folder myself but dragging and dropping each disc content into the STEAM folder I made without making anything duplicates or anything.

    BUT THEN, I was looking around on Omnisphere and found that if I click on the SPECTRASONICS icon on the home screen of Omnisphere, it brings you to that screen of where you can check for updates. There's a "DIAGNOSTICS" button on that same page, when I clicked it. It tells you the folder path at which Omnisphere searches for the STEAM folder. & mine says that it is searching in the "STEP 2" folder of the installation or torrent file that gets downloaded. It doesn't say its looking in the APPLICATION SUPPORT folder.

    SO NOW MY QUESTION IS:
    HOW DO I GET OMNISPHERE TO LOOK FOR THE STEAM FOLDER IN A DIFFERENT FOLDER ON THE COMPUTER OR HOW DO I CHANGE THE PATH AT WHICH OMNIPSHERE SEARCHES FOR THE STEAM FOLDER?
     
  5. momo

    momo Rock Star

    Joined:
    Jul 23, 2014
    Messages:
    944
    Likes Received:
    477
    Location:
    Floating Amongst the Stars
    Im on windows but can tell ya how it works sort of.
    Search for SPECTRASONICS on your mac there should be two folders with that name,
    open the folder with .dat files in it these are the keys and can be named AUDIO13.dat AUDIO14.dat ect
    There should be a shortcut folder in the SPECTRASONICS folder as well with the dat files
    this is the shortcut folder that tells Omnisphere where to look for the sounds.
    Open an other browser window and go to where your steam folder is, this should be inside the other SPECTRASONICS folder but with an Omnisphere folder in it and the sounds inside that .
    Make a shortcut from the steam folder, into the other SPECTRASONICS folder you opened with the dat files
    making sure it just said steam, on windows when making a shortcut the name shortcut gets added so its called
    steam-shortcut so if its the same on mac rename it to just steam and it should work.

    This is some info posted by an other mac user that has helped never got his name do but could come in handy.

    What to download for a proper full O2 install:
    1: Spectrasonics.Omnisphere.2.DVDR.D1.PROPER-R2R
    2: From D2 to D8 released by DYNAMiCS
    3a(WiN): Spectrasonics.Omnisphere.v2.0.Patch.and.Keygen.Only-R2R
    3b(MAC): Spectrasonics.Omnisphere.v2.0.3d.MacOSX.Incl.Patched.and.Keygen-HEXWARS

    --------------------------

    How to install and authorize:
    1: Mount D1-PROPER-R2R, and D2-D8 DYNAMiCS,
    start installation with "Step 1 - Installer", continue until finished, will take long time.
    2: Install "Step 2 - Data Updater" from DYNAMiCS release.
    3: Optionally install "Step 3 - For Trilian Users" and "Step 4 - For Moog Tribute Users"
    4: Install R2R Patch.and.Keygen or HEXWARS.Patched.and.Keygen.
    5: Start plug-in patch them with keygen and copy challenge code, input to keygen,
    generate a response and paste it into Omnisphere2 auth window.
    6: Relaunch plug and enjoy !

    ==========================


    Solutions:

    1) To get the PKGs to install properly try using BatchChmod on your STEAM folder after installing
    all library content (tick all subfolders and files). This fixed problems on an external disk with
    moog update and other updates for me.

    2) To fix activation issues - Try copying .component and .vst files and place
    those in: user/Library/Audio/Plug-ins/Components & user/Library/Audio/Plug-Ins/VST .
    Also copying hexwars VST and put it in: user/LibraryApplication Support/Spectrasonics/Audio/Plug-Ins/VST
    (if you don’t have these folders create them), copying the hexwars
    .component into: user/LibraryApplication Support/Spectrasonics/Audio/Plugins/Components
    (again create if it’s not there) as well as putting the .dpm wrapper file in
    : user/LibraryApplication Support/Spectrasonics/Application Support/Digidesign/Plug-ins
    (create if it's not there) . Worked for me.

    3) Once installed, use R2R keygen to install other updates found elsewhere
    (I have installed 2.1.0d (library and main program), 2.1.0e & 2.1.0f
    (for library) in that order). Patch the .VST and .Component files. Copy .VST and .Component to desktop
    where can navigate to via R2R keygen and a keygen app (i.e. one from Dada).
    Though they show as folders via keygen app, navigate into them until you find
    a file in a folder called “MacOS”… that’s what you patch. Fixing patch errors
    by BatchChmod'ing offending files ticking include subfolders/files
    (i.e. I did in the case of VST plugin as it failed to patch first time).
    Copy back VST and Component to the 4 locations I mentioned above.

    4) Once library installed no need to re-install fully again on another system if i.e.
    you're using external hard-drive. Simply initiate installation of program and library,
    let it get to the point where it says to insert the first disc and then quit out from
    the installer (I force quitted it). Then repeat steps above.
     
  6. Bigg Bey

    Bigg Bey Newbie

    Joined:
    Dec 4, 2017
    Messages:
    15
    Likes Received:
    2
    @DLord did that resolve your issue because I have a similar problem and don't want to make a post if this did. Mine is so messed up I see all the sound Omnisphere is not recognizing them
     
  7. Bigg Bey

    Bigg Bey Newbie

    Joined:
    Dec 4, 2017
    Messages:
    15
    Likes Received:
    2

    Question I installed on mac but didn't have the trillian or moog. I copied the STEAM folder from a friend who had it on windows now i am getting errors saying my STEAM folder doesn't have write premissions and i can't get any sounds to play. should i do this?
     
Loading...
Similar Threads - Spectrasonics Omnisphere help Forum Date
Spectrasonics Omnisphere 2 Installation Problem.. Please Help Software Nov 16, 2016
need help extracting spectrasonics omnisphere 2 Software Aug 31, 2016
Spectrasonics Omnisphere HELP!!!! PC Oct 26, 2011
Spectrasonics Omnisphere 2.5 is here ! Industry News Jul 19, 2018
Spectrasonics Omnisphere 2 Installation Problem on High Sierra 10.13.4?? Software Jun 11, 2018
Loading...