Omnisphere 2: Cannot Install 2.1.0d and 2.1.0e Library Update

Discussion in 'PC' started by mabilon, Sep 6, 2015.

Tags:
  1. mabilon

    mabilon Newbie

    Joined:
    Sep 6, 2015
    Messages:
    10
    Likes Received:
    0
    Hello,

    I'm on Windows7 and I've installed the Software Update 2.1.0d. Everything was fine with it.

    Then I've tried to install the Patch Library Update (Data Updater) 2.1.0d and 2.1.0e for updating the library.....but I cannot install any of them with success! Everytime I receive an error message that says:

    " C:\ProgramData\Spectrasonics\STEAM\Omnisphere\Defaults\Factory\default factory.mlt_omn

    an error occured while trying to read the source file: the system canno find the path specified.

    Click Retry to try again, Ignore to skip this file (not recommended), or Abort to cancel installation. "

    [​IMG]


    This is very strange, because I originally installed the STEAM folder in the default path, never moved it and I checked the error path and I actually have this default factory.mlt_omn in the correct place.

    What I need to do?

    Thanks
     
  2.  
  3. mono

    mono Audiosexual

    Joined:
    Jul 23, 2014
    Messages:
    1,065
    Likes Received:
    620
    Location:
    Floating Amongst the Stars
    The only files that are in the folder C:\ProgramData\Spectrasonics\
    are your keys AUDIO dat files and a short-cut to your STEAM folder
    try remake the short-cut folder or check to see if its there,

    ho and hi welcom to audiosex :wink:

    just remembered i didnt install the steam folder into the default path
    so it could be in there as well ? if not the frist fix should work
     
    Last edited: Sep 6, 2015
  4. mabilon

    mabilon Newbie

    Joined:
    Sep 6, 2015
    Messages:
    10
    Likes Received:
    0
    Hi,

    thanks for your help. Unfortunately the shortcut is not there. If I remember right, the last time I made a library update I got some sort of error, and after checking a solution on the web I've read that the problem was the shortcut. So I just deleted it and then the updated worked...

    So now there is no shortcut anymore. I confirm that I've installed the STEAM folder in the default path, and never moved it. Some time ago I also installed Trilian update library (for having trilian working on Omnisphere 2) and it worked. I don't know if this can be related or not, but I don't think so.

    I really don't know what to do. Reinstalling everything doesn't seem ideal, since I've worked some time already on Omnisphere 2, sorted many things into projects, gave stars to the various sounds in order to classify them......I would lose a lot of time if I need to redo all this again from scratch.

    Still hope someone can give me a solution :)
     
  5. Guitarmaniac64

    Guitarmaniac64 Platinum Record

    Joined:
    Jun 5, 2011
    Messages:
    1,105
    Likes Received:
    186
    Unpack the installer and move the files manually to the steam folder thats what i had to do with manu updates on version 1
     
  6. mabilon

    mabilon Newbie

    Joined:
    Sep 6, 2015
    Messages:
    10
    Likes Received:
    0
    I really don't know how to do this and to be honest I'm really worried of doing some mistakes. On thepdf file attached it is clearly indicated to NOT move around manually files or mess with the STEAM folder. They says to just run the EXE installer file and not doing anything else... :/
     
  7. GuestStar

    GuestStar Ultrasonic

    Joined:
    Feb 8, 2014
    Messages:
    70
    Likes Received:
    24
    I had the same issue and moved all files on my own. It's very easy.
    You should copy the Steam directory (updated file) over the steam directory (to update).
    Chose overwrite all. And all old files will be overwritten by the new files. On the diagnostic menu you can see the updated status.
     
    Last edited: Sep 6, 2015
  8. mabilon

    mabilon Newbie

    Joined:
    Sep 6, 2015
    Messages:
    10
    Likes Received:
    0
    I'm checking the STEAM folder in the updated file. There seems to be some path changes between the two! think this can result in a big mess. Here what I mean:

    -path on the Old STEAM folder (already installed on PC): STEAM >Omnisphere > here I find the folder "Default" and the folder "Setting Library". Inside "Setting Library" folder I find the folder "Patches".

    -path on the New STEAM folder (to be installed): STEAM > Omnisphere > Setting Library > Here I find both "Defaults" and "Patches" folders.

    So if I simply copy the STEAM directory on the old one, I will find myself having two "Defaults" Library on the hard drive: the old one installed where it is now + the new one that now is placed after "Setting Library". In the new update it seems that they decided to place the "Defaults" folder after the "Setting Library" folder, while now it is located only after the "Omnisphere" folder.

    I don't know if I've been clear enough. Actually I'm thinking that this could the cause of the installation problem? But if this is the cause, why many other people succeded in intalling it without issues?
     
  9. mono

    mono Audiosexual

    Joined:
    Jul 23, 2014
    Messages:
    1,065
    Likes Received:
    620
    Location:
    Floating Amongst the Stars
    you will have to remake a short cut folder there for the updates to find the files
    and you should backup some files as well befor you update them as some users were getting errors after updating,
    in C:\ProgramData\Spectrasonics\STEAM\Omnisphere\Defaults\
    backup of the hole default folder
    then in the settings library back up the user tags folder,

    if that dont work do what guitarmaniac64 & gueststar said cause it will work and is east to do
    you will also get a chance to back-up anything elace you see in the update steam folder
    befor you replace them with the updates,
     
  10. mabilon

    mabilon Newbie

    Joined:
    Sep 6, 2015
    Messages:
    10
    Likes Received:
    0
    Hi momo, thanks for your suggestion......but how do I remake a shortcut folder there? Can you tell me what to do, step by step, in order to do things right?

    Thanks!!
     
  11. mono

    mono Audiosexual

    Joined:
    Jul 23, 2014
    Messages:
    1,065
    Likes Received:
    620
    Location:
    Floating Amongst the Stars
    right click your STEAM folder copy
    then go to C:\ProgramData\Spectrasonics\
    right click in your Spectrasonics folder and paste shortcut
    a other user had the same sort of error a few days ago and this fixed it,
    you will have to delete the other shortcut folders there as well
    or you can point one to the right folder is easer to just make a new shortcut do

    https://audiosex.pro/threads/omnisphere-2-cant-find-core-libraries.20314/#post-133619
     
  12. mabilon

    mabilon Newbie

    Joined:
    Sep 6, 2015
    Messages:
    10
    Likes Received:
    0
    Hi Momo,

    my STEAM folder is already located (since I made the default installation) into C:\ProgramData\Spectrasonics\STEAM

    so.... I've tried copying it, and then "paste shortcut" into the same plce. So now in the same place I have the STEAM folder + the STEAM shortcut folder.

    Tried again the installation and got the same error. Tried renaming the shortcut exactly "STEAM" and tried again: doesn't work again....

    Unfortunatley it doesn't seem to work! Really don't know what to do....this really sucks!
     
  13. Mykal

    Mykal AudioP2P

    Joined:
    Jun 20, 2011
    Messages:
    1,365
    Likes Received:
    446
    Location:
    I'm Right Behind You
    Contact Customer support
     
  14. mono

    mono Audiosexual

    Joined:
    Jul 23, 2014
    Messages:
    1,065
    Likes Received:
    620
    Location:
    Floating Amongst the Stars
    you can try use this defalts folder is 200kb
    http://www16.zippyshare.com/v/PWNkGFU3/file.html
    move you own folder to your desktop and replace with this one then try update again
    if it works copy the users settings.xml and user settings factory.xml from your back up into your defalts folder ?

    ps, dont forget to refresh your database
     
  15. mabilon

    mabilon Newbie

    Joined:
    Sep 6, 2015
    Messages:
    10
    Likes Received:
    0
    Thanks again Momo, but this doesn't work again.

    I think (maybe I'm wrong) that the error is due to the different path structure of the New STEAM (to be installed) and the old STEAM (already installed). As said before, the "Defaults" folder is located in two differen locations in the two STEAM folders. So, when running the update, probably the update program cannot find the "Defaults" folder due to the different path structure.

    I don't know what else could be. In any case, u think this makes it almost impossible to simply "copy" the new STEAM folder as suggested before, because I would end with 2 different "Defaults" folders located in two different paths. At that point, what I need to do? delete the old one? keep both? And which one is the correct path in the end? :/
     
  16. mono

    mono Audiosexual

    Joined:
    Jul 23, 2014
    Messages:
    1,065
    Likes Received:
    620
    Location:
    Floating Amongst the Stars
    just checked and i have two there as well lol ?
    the updates go into your Setting Library so you can copy the files into there
    and just keep the two default folders,
     
  17. mabilon

    mabilon Newbie

    Joined:
    Sep 6, 2015
    Messages:
    10
    Likes Received:
    0
    I've just decided to take the risk and trying: unfortunately also this doesn't seem to work! Soundsources and patches are still the older version....

    [​IMG]

    Now the situation is worst than before. Library didn't update and I've also messed up with STEAM folder. So now, what to do?
     
  18. mono

    mono Audiosexual

    Joined:
    Jul 23, 2014
    Messages:
    1,065
    Likes Received:
    620
    Location:
    Floating Amongst the Stars
    hit the diagnostics tab did you refresh the database ?
     
  19. mabilon

    mabilon Newbie

    Joined:
    Sep 6, 2015
    Messages:
    10
    Likes Received:
    0
    I hitted the diagnostic, here the screenshot:

    [​IMG]

    I've also entered omnisphere and hit refresh button into the soundsource, multi and patch library menu's. Then closed Omnisphere 2 and reopened again: nothing of nothing again!
     
  20. mono

    mono Audiosexual

    Joined:
    Jul 23, 2014
    Messages:
    1,065
    Likes Received:
    620
    Location:
    Floating Amongst the Stars
    the factory patch dbs should be 524 not 522 ?
    ill send you a pm in a min
     
  21. mono

    mono Audiosexual

    Joined:
    Jul 23, 2014
    Messages:
    1,065
    Likes Received:
    620
    Location:
    Floating Amongst the Stars
    ok we got it sorted from the looks of things there is a bad update going around
     
    Last edited: Sep 7, 2015
Loading...
Similar Threads - Omnisphere Cannot Install Forum Date
Cannot figure out how to install Omnisphere Software Dec 19, 2018
Cannot extract Omnisphere 2.6 Omnisphere May 9, 2020
Cannot Get Omnisphere 2.6 to work Software Apr 11, 2020
Cannot save patches in Omnisphere 2 Software Apr 8, 2019
my omnisphere cannot load soundsourceneed help i think Software Mar 23, 2018
Loading...