Omnisphere 2.6.2 problem with FL studio

Discussion in 'Software' started by Zein, Oct 17, 2019.

  1. Zein

    Zein Newbie

    Joined:
    Oct 17, 2019
    Messages:
    2
    Likes Received:
    0
    Hello,

    I installed omnisphere and so far, everything work on standalone

    but when i try to use it on FL studio each time, he ask me the challenge code (and each time it did, even the standalone ask me again the challenge code if i launch it after).

    • Challenge code on FL studio > No effect (relaunch FL change nothing - delete the vst on FL studio and re-install it change nothing)
    • Challenge code on Standalone after the FL fail > Work but only for the standalone.

    So i'm pretty lost and don't have solutions.

    Thanks for the help.
     
    • Interesting Interesting x 1
    • List
  2.  
  3. mono

    mono Audiosexual

    Joined:
    Jul 23, 2014
    Messages:
    1,064
    Likes Received:
    607
    Location:
    Floating Amongst the Stars
    @Zein
    you need to patch the plugins first with the keygen then enter the challenge code,
    there are two vsti that need to be patched ,one for the standalone and the other for use in fl studio
    they can sometimes be found here.
    C:\ProgramData\Spectrasonics\Plug-ins\64bit\Omnisphere.dll
    C:\Program Files\Vstplugins\Omnisphere.dll

    After that run fl studio as administrator and enter the challenge code into Omnisphere
    and it should be working ok if all went well.
     
    • Winner Winner x 2
    • Like Like x 1
    • List
  4. Zein

    Zein Newbie

    Joined:
    Oct 17, 2019
    Messages:
    2
    Likes Received:
    0
    Thank you for the answer, i'd already try that before but i have Failed patching when i try to patch theses one :
    C:\ProgramData\Spectrasonics\Plug-ins\64bit\Omnisphere.dll

    [​IMG]

    The patch work only here :
    C:\Program Files\Steinberg\vstplugins\Omnisphere.dll

    I don't know why but i have 4 omnisphere dll, the patch work only for 1.

    [​IMG]
     
    • Interesting Interesting x 1
    • List
  5. DJK

    DJK Rock Star

    Joined:
    Nov 23, 2017
    Messages:
    785
    Likes Received:
    353
    Location:
    felixstowe england
    the main .dll is the vst and 2 in program data, 1 in program data always have failed patching, if you use x64 delete the x32 .dll
    or if that dont work you can move the .dll`s to your desktop patch them and then move them back
     
    • Like Like x 2
    • Winner Winner x 1
    • List
  6. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    2,348
    Likes Received:
    2,045
    @Zein Another unnecessary Omnisphere thread BY A NEWBIE with the same problem as 100 previous one. This is nothing new and has already been explained several times. All these threads should be reported to @Olymoon so they are deleted as soon as they show up. In case this thread survives, here is, for the 10000th time the solution to this issue.
    There are two possible answers when the failed patching appears. One is that you already have patched the dll. When a dll is already patched you will receive a "Failed patching" message as you can't repatch it. The other is that you don't have the necessary permissions to that file. I am not going to repeat a whole set of permissions all over again because your problem is that you did not delete the old 32bit version of Omnisphere dlls. In order for version 2.6.2 to work, you must delete the dlls from
    C:\Program Data\Spectrasonics\plugins
    C:\Program Files (x86)\Steinberg\vstplugins
    Once deleted try running Omnisphere. If it does not work then all you need to do is copy the one in C:\Program Files\Steinberg\plug-ins and copy it onto C:\ProgramData\Spectrasonics\plugi-ins\64bit. This is because you said that it is already patched. In case, the "Failed patching" message was caused by the old 32bit dlls you must patch the 64bit ones.
     
Loading...
Similar Threads - Omnisphere problem studio Forum Date
Problem with screen fitting on omnisphere Software Oct 17, 2019
Spectrasonics Omnisphere 2 (Problem on High Sierra 10.13.6) help Software Sep 26, 2019
Problems authorising omnisphere Software Sep 14, 2019
Problem with Omnisphere 2.5 in Mac OSX Mojave 10.14.5 Mac / Hackintosh Jul 22, 2019
Omnisphere Keyscape Amp Problems Software Jul 8, 2019
Loading...