Native Instruments The installation failed

Discussion in 'Software' started by Don Choi, Jan 28, 2020.

  1. Don Choi

    Don Choi Newbie

    Joined:
    Jan 28, 2020
    Messages:
    2
    Likes Received:
    0
    Hello, I just noticed a lot of Native Instruments programs are facing installation failure since Mac OS Catalina.

    So far, I wasn't able to install recent updates of Reaktor/Battery/Kontakt/Absynth/Maschine packs, and all the programs under each programs since I can't update the most recent updates. (For example, I can't update Reaktor 6.3.1 without installing Reaktor 6.2.1. And, I can't install Reaktor 6.2.1.)

    I have attached a screenshot of installer. The wording goes like this.

    [​IMG]

    "An error occurred during installation.
    The installation failed.
    The installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance."



    Here is the Installer log from when I install Reaktor 6.

    I don't know what cause this failure, and if you know how to resolve it, please let me know.




    ---------------------------------------------------------------------------------------------------------------------
    Jan 28 15:00:07 Dawns-iMac-Pro Installer[11493]: Package Authoring Error: <background> has an unsupported MIME type: image/data
    Jan 28 15:00:07 Dawns-iMac-Pro Installer[11493]: Package Authoring Error: <background_scaling> has an unsupported MIME type: X-NSObject/NSNumber
    Jan 28 15:00:07 Dawns-iMac-Pro Installer[11493]: Package Authoring Error: <background_alignment> has an unsupported MIME type: X-NSObject/NSNumber
    Jan 28 15:00:07 Dawns-iMac-Pro Installer[11493]: Package Authoring Error: <layout-direction> has an unsupported MIME type: X-NSObject/NSNumber
    Jan 28 15:00:08 Dawns-iMac-Pro Installer[11493]: Failed to load specified background image
    Jan 28 15:00:08 Dawns-iMac-Pro Installer[11493]: Could not load resource readme: (null)
    Jan 28 15:00:19 Dawns-iMac-Pro installd[617]: PackageKit: ----- Begin install -----
    Jan 28 15:00:19 Dawns-iMac-Pro installd[617]: PackageKit: Removing directory (/Library/InstallerSandboxes) path has invalid attributes.
    Jan 28 15:00:19 Dawns-iMac-Pro installd[617]: PackageKit: Failed to rmdir(/Library/InstallerSandboxes). Directory not empty
    Jan 28 15:00:19 Dawns-iMac-Pro installd[617]: PackageKit: Removing directory (/Library/InstallerSandboxes) path has invalid attributes.
    Jan 28 15:00:19 Dawns-iMac-Pro installd[617]: PackageKit: Failed to rmdir(/Library/InstallerSandboxes). Directory not empty
    Jan 28 15:00:19 Dawns-iMac-Pro installd[617]: PackageKit: Removing directory (/Library/InstallerSandboxes) path has invalid attributes.
    Jan 28 15:00:19 Dawns-iMac-Pro installd[617]: PackageKit: Failed to rmdir(/Library/InstallerSandboxes). Directory not empty
    Jan 28 15:00:22 Dawns-iMac-Pro installd[617]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “Reaktor 6 v6.2.1 Update.pkg”." UserInfo={NSFilePath=./postinstall, NSURL=file:///Volumes/NI%20Reaktor%206%20v6.2.1/Reaktor%206%20v6.2.1%20Update.pkg#Reaktor%206%20Application.pkg, PKInstallPackageIdentifier=com.native-instruments.Reaktor6.Application, NSLocalizedDescription=An error occurred while running scripts from the package “Reaktor 6 v6.2.1 Update.pkg”.} {
    NSFilePath = "./postinstall";
    NSLocalizedDescription = "An error occurred while running scripts from the package \U201cReaktor 6 v6.2.1 Update.pkg\U201d.";
    NSURL = "file:///Volumes/NI%20Reaktor%206%20v6.2.1/Reaktor%206%20v6.2.1%20Update.pkg#Reaktor%206%20Application.pkg";
    PKInstallPackageIdentifier = "com.native-instruments.Reaktor6.Application";
    }
    Jan 28 15:00:22 Dawns-iMac-Pro installd[617]: PackageKit: Removing directory (/Library/InstallerSandboxes) path has invalid attributes.
    Jan 28 15:00:22 Dawns-iMac-Pro installd[617]: PackageKit: Failed to rmdir(/Library/InstallerSandboxes). Directory not empty
    Jan 28 15:00:22 Dawns-iMac-Pro installd[617]: PackageKit: Removing directory (/Library/InstallerSandboxes) path has invalid attributes.
    Jan 28 15:00:22 Dawns-iMac-Pro installd[617]: PackageKit: Failed to rmdir(/Library/InstallerSandboxes). Directory not empty
    Jan 28 15:00:23 Dawns-iMac-Pro Installer[11493]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
    Jan 28 15:00:23 Dawns-iMac-Pro Installer[11493]: Displaying 'Install Failed' UI.
    Jan 28 15:00:23 Dawns-iMac-Pro Installer[11493]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.
    ---------------------------------------------------------------------------------------------------------------------
     

    Attached Files:

  2.  
  3. Talula

    Talula Platinum Record

    Joined:
    Apr 22, 2018
    Messages:
    775
    Likes Received:
    213
    just install lastest 6.3.1 version
     
  4. Don Choi

    Don Choi Newbie

    Joined:
    Jan 28, 2020
    Messages:
    2
    Likes Received:
    0
    This is what happens when I run 6.3.1 installer.
    "Failure
    No previous installation found.
    Please run the full product installer before running this update installer."
    [​IMG]
     

    Attached Files:

  5. Talula

    Talula Platinum Record

    Joined:
    Apr 22, 2018
    Messages:
    775
    Likes Received:
    213
    You try install update.
    Download FULL latest version installer. You can request installer here:
    https://www.native-instruments.com/en/products/komplete/synths/reaktor-6/downloads/

    BUT! Note from NI:
    This product is currently officially not compatible with macOS 10.15 Catalina
     
    • Interesting Interesting x 1
    • List
Loading...
Loading...