Library successfully loaded but did not appear in Kontakt

Discussion in 'Kontakt' started by Axl28, Mar 22, 2019.

  1. Axl28

    Axl28 Newbie

    Joined:
    Mar 22, 2019
    Messages:
    5
    Likes Received:
    1
    Hello

    I have a problem with loading sound libraries including the non third-party ones. I cannot load libs with only nkx and nkc files (no library found error) so what I did is I downloaded a wallpaper and created self-made nicnt files using someone's generator...then this appeared. I made sure the snpid is unique.
    https://imgur.com/a/06S5MJh

    Upon startup, there's no solo strings library to be found. I was able to load Albion I and II on 5.5.0 unlocked version except for this one I'm currently using 5.6.8 from symlink installer. Last night I read something about clearing library cache but when I checked the root folder, I cannot find any folder named library cache.

    While others do not need the add library option because I can just load the nki files using files tab, there are some libs that need the add library so I cannot use those too.

    It's my first time doing this kind of thing as I'm only used to downloaded cracked adobe apps.
    Any help is greatly appreciated. :(
     
  2.  
  3. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    709
    Likes Received:
    708
    Location:
    Middle of Ocean
    @Axl28 First, I dont know why you are stuck on 5.6.8 when we have 6.0.4.:dunno: Now, to your question.
    Go to upper left hand side and open Options. There you find a Libraries tab. Open it and it will tell you "Selected Libraries are visible in the library browser" Make sure the one is missing is selected. If it does not show up, go to your Service Center folder and make sure that the XML file for that library does have the correct SPIND number.
     
    Last edited: Mar 22, 2019
  4. Axl28

    Axl28 Newbie

    Joined:
    Mar 22, 2019
    Messages:
    5
    Likes Received:
    1
    Thank you, I think I overlooked that instruction because the libs work now!
    EDIT: I think I won't upgrade to higher versions any time soon. I just happen to stumble upon this version so I'll use this for now.
     
  5. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    709
    Likes Received:
    708
    Location:
    Middle of Ocean
    New libraries require new version and you can keep the old version even if you install the new Kontakt 6
     
  6. Axl28

    Axl28 Newbie

    Joined:
    Mar 22, 2019
    Messages:
    5
    Likes Received:
    1
    Reconsidered this option when I found out that I'm having another set of problems in other libs such as spitfire percussion.
    There are no samples on the dropdown browse menu unlike realivox blue. The other problem is the artist series of tina guo...when I open the 5.6.8 symlink, it shows the error on capture1 image file then 6.0.2 no install on capture2...

    I'm legit confused rn ;~;
     

    Attached Files:

  7. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    709
    Likes Received:
    708
    Location:
    Middle of Ocean
    @Axl28 First, you need to make sure that the add library in your KOntakt 6 is fixed. There was some problems with earlier versions of K6. I TOLD you that 6.0.4 is the latest so i dont know why you installed the older version :dunno: What is the benefit? Now, I had 6.02 and had no problems but i had the fix for the add library. Please install 6.0.4 and follow instructions for the add library. After that if you have the same problem, you need to repeat the same steps I explained in my first post. I have all libraries you mentioned. Check your PM

    Which version of K6 did you install?
     
  8. Axl28

    Axl28 Newbie

    Joined:
    Mar 22, 2019
    Messages:
    5
    Likes Received:
    1
    Ok I installed the 6.0.4 version from rutracker and completely followed the instructions for installation then I also followed what you told me and still the problem persists. I'm not sure what to do so I used two different nicnt generator. '

    The first followed the correct number like spitfire perc - 899 with the xml file and the other generated its own I think. For some reason, when I use the nicnt from the first generator, it says no library found and then the other file is recognized but there are no samples on the dropdown menu. Could it be the library itself? I apologize in advance english is not my native language. ^^'
     
  9. Ellin

    Ellin Ultrasonic

    Joined:
    Sep 20, 2015
    Messages:
    101
    Likes Received:
    28
    Location:
    Italy
    I don't know if it can be useful, but this is my experience: I add all libreries in Kontakt 5.6.5, then use Kontakt 6.0.4 Some libraries only appear in Kontakt 6.0.4 Library Tab even if they were added with 5.6.5 ...
     
  10. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    709
    Likes Received:
    708
    Location:
    Middle of Ocean
    Ellin that is an option that was used several versions back due the problems that have been corrected. I have 6.0.4 and I have not found a single library that I cant install. BTW, I still have my 5.6.5 exe.:like: Most likely the OP is doing something wrong during install or he needs to make sure that al registry entries for those libraries are deleted before he tries to reinstall them.
     
  11. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    709
    Likes Received:
    708
    Location:
    Middle of Ocean
    Do me a favor. Send me by PM the 2 NICNT you are using. Another thing, I want you to try a library that you never have installed before. Just make sure that the SPIND is not used by anyone else. Also I am going to send you a program that is going to automatically look up the registry keys for those libraries you are having problems with. I want you to delete them. Finally, I want you to look for every xml file in Service Cetre that belongs to those libraries and delete them. Make sure you check for more than one xml file. Sometimes you find 2 or 3 depending on the number of SPIND you have used.
     
  12. twoheart

    twoheart Rock Star

    Joined:
    Nov 21, 2015
    Messages:
    706
    Likes Received:
    358
    Location:
    Share many
    Most likely there is a collision with other installed Libraries (not the Kontakt version) as I got those errors on Kontakt 6.0.4 as well.

    All those Libs with a self made .NICNT file carry the risk to collide with other Libs because only NI organizes the SNPID numbers.

    The problem is the SNPID inside the .NICNT file. The SNPID consists of a string of 3 letters and numbers, e.g. "998", "99A", "11C" and so on.

    All Libraries are registered in the System Registery AND in a directory on your computer called "Service Center" under c:\Program Files\Common Files\Native Instruments\Service Center\
    Whenever the name and/or the SNPID exists on your computer either in the Registry or in the Native Instruments "Service Center" you may encounter problems.

    To solve the issues you'll need to know wich (original and non original) Libraries are installed, how they are named and how their SNPID is.
    There are some helpful programs available on on this site e.g. to list all SNPIDs used on your system ( @The Pirate will send it to you as he said in his last post :wink: )

    For editing the NICNT file you could use the freeware Notepad++
     
    Last edited: Mar 23, 2019
  13. jazzzz

    jazzzz Kapellmeister

    Joined:
    Mar 13, 2018
    Messages:
    167
    Likes Received:
    46
    Are the .nki files in the Instruments folder inside the library's folder?

    And other thing is, if you created two different .nicnt files for the same library (using the same name for the .nicnt), it can cause a conflict.
    Try deleting the library from the Registry, check if there are more than one folder related to that library. To get there:
    Type regedit in Start menu in the search field, when it appears as a result, right-click on it and choose "Run as administrator".
    In Regedit navigate to this location:
    HKEY_CURRENT_USER > Software > Native Instruments
    Here if you find the library, delete it with its contents.
    I'm not sure if restarting windows is needed but it can't hurt to do so.
    Then try to add the library again, with only one of the different created .nicnt files. That .nicnt must be located in the main folder of that instrument library.
     
  14. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    709
    Likes Received:
    708
    Location:
    Middle of Ocean
    @twoheart and @jazzzz The only way for the OP to find out whether it is a Kontakt install problem, or a library problem is by installing a completely different library and take it from there. With new library with its own NICNT all he needs to do is find out whether another library is using the same SPIND. If the library install without problems, it is the NICNT and registry for those 2 libraries. If the new library fails, his best option is to completely uninstall Kontakt 5 and Kontakt 6 and do a clean install.
     
  15. twoheart

    twoheart Rock Star

    Joined:
    Nov 21, 2015
    Messages:
    706
    Likes Received:
    358
    Location:
    Share many
    Yes, and it should be an original Library with an original NICNT file otherwise you can't distinguish between the errors as you intend.
     
  16. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    709
    Likes Received:
    708
    Location:
    Middle of Ocean
    @Axl28 I sent you the SPIND Locator, NCINT Generator, the Library Dropper, and The Registry Explorer.
    Here are some instructions and a clean NCINT file

    1.jpg
    2.jpg
    3.jpg
    4.jpg 4.jpg
     
    Last edited: Mar 23, 2019

    Attached Files:

  17. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    709
    Likes Received:
    708
    Location:
    Middle of Ocean
    5.jpg

    5.jpg
    7.jpg
    8.jpg
     

    Attached Files:

    • 6.jpg
      6.jpg
      File size:
      194.1 KB
      Views:
      3
  18. Axl28

    Axl28 Newbie

    Joined:
    Mar 22, 2019
    Messages:
    5
    Likes Received:
    1
    I just downloaded two new libraries and ran in the newest kontakt without any problems.
    I'll send the nicnt and re-check files once I get home from work. And thanks for the help guys!
     
  19. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    709
    Likes Received:
    708
    Location:
    Middle of Ocean
    Exactly what I thought. Check in the tools I sent you. There is one that will check all the NI registry and will allow you to delete whichever one you chose. You re going to delete the registry entries for those 2 libraries. And them you are going to do what I explained to you with the NICNT files.
     
Loading...
Loading...