Kontakt 5.6.6 portable

Discussion in 'Kontakt' started by gaijinn000, Apr 29, 2017.

  1. gaijinn000

    gaijinn000 Noisemaker

    Joined:
    Aug 23, 2016
    Messages:
    46
    Likes Received:
    3
    Hello fellow Kontakters...anyone using this version? And if so are there any issues with it?
    Thanks
     
  2.  
  3. Spiritos

    Spiritos Noisemaker

    Joined:
    May 4, 2013
    Messages:
    106
    Likes Received:
    5
    Location:
    Amsterdam
    Just installed it including the 5.6.8 Update and it runs marvelous including running libraries which my installed 5.5.2 version wouldn't activate. Can also run it simultaenously in one Live session. Only issue I'm having is it messes up Live's ability to restore crashed sessions -which I'm looking into.
     
  4. Zikkk

    Zikkk Producer

    Joined:
    Dec 29, 2015
    Messages:
    92
    Likes Received:
    81
    Location:
    Between A and B♭
    I'm still using 5.5.0, due to Komplete Kontrol compatibility issues. I was always afraid I would lose one of them or both permanently. There are still many things I don't understand, especially concerning registry entries.
    I wonder if it is possible to use 5.6.8 portable together with 5.5.0. Are there any common files that will be overwritten? And what about Komplete Kontrol and Maschine? Will they be affected by another Kontakt installation?
     
  5. Spiritos

    Spiritos Noisemaker

    Joined:
    May 4, 2013
    Messages:
    106
    Likes Received:
    5
    Location:
    Amsterdam
    I use 5.5.2 along with the portable version. Works perfect!

    PS. Some people don't even install the portable version, but I did. Just make sure you install it on the OS drive/partition.

    EDIT: PS. Thing is -as far as I can tell even installing doesn't really "install" a thing and no new folders as far as I can tell. Relative downside of this btw. is I don't (yet) know how to troubleshoot for eg. one particular library which still won't activate since the portable version doesn't seem to use a Service Center where like the regular one where you could alter the .XML file with the .NCINT (which solves a lot of issues with 5.5.2).
     
    Last edited: Aug 27, 2017
  6. Peter Krav

    Peter Krav Producer

    Joined:
    Jun 23, 2017
    Messages:
    169
    Likes Received:
    96
    Location:
    Завод Юпітер
    You can restore Live's sets manually (after a crash), rollback to 7,2 if your problem persist
     
  7. Spiritos

    Spiritos Noisemaker

    Joined:
    May 4, 2013
    Messages:
    106
    Likes Received:
    5
    Location:
    Amsterdam
    @Peter Krav: Thanks for the tip! Can I ask if this is how you solved this issue yourself? Thing is I've looked pretty extensively on the web for this error and I couldn't fine one which addresses the same combo of Ableton + Kontakt portable. I know the portable version uses a different technique than before so it does make sense new issues arise but Ableton has had a long history regarding this error and as far as I can tell hasn't really solved it and it has always been the 3rd party (like Positive Grid) needing to release an update for the VST to make it work.

    Also, what do you mean by restoring a set manually? How does this differ from the default way where Live asks you to restore the crashed session? Tnx.
     
  8. Peter Krav

    Peter Krav Producer

    Joined:
    Jun 23, 2017
    Messages:
    169
    Likes Received:
    96
    Location:
    Завод Юпітер
    No, i don't have Kontak 5.6.8 and i don't have this issue but give it a try 7,2 is more stable version, i had issues with 7,3 but i have a support.
    When Live fail to recover your work for some reason you can do it manually follow this instructions
    https://help.ableton.com/hc/en-us/articles/209775425-Recovering-a-Live-Set-manually-after-a-crash
     
  9. Spiritos

    Spiritos Noisemaker

    Joined:
    May 4, 2013
    Messages:
    106
    Likes Received:
    5
    Location:
    Amsterdam
    I see. Quite a hassle all in all -especially if it happens all the time but nevertheless thanks for pointing me to a solution in case of emergency.

    As for Live 9.7.2 vs 9.7.3 that's not really gonna make a difference. Problems arising with "undo history" have been a reoccuring issue with Live since Live 3 or 4. It's rooted deep in the code of the module and like I wrote untill now all issues needed to be adressed by the VTS-developers as Live can't seem to do anything about it -almost the same as the PDC-latency issue being so deeply integrated in the code it would require a complete re-build of Live.

    I just hope someone else also encountered this issue -either with Kontakt or another VST and found a workaround to deal with this.
     
  10. Spiritos

    Spiritos Noisemaker

    Joined:
    May 4, 2013
    Messages:
    106
    Likes Received:
    5
    Location:
    Amsterdam
    I just ended up reinstalling Live 9.7.3 again and now all seems to work just fine. Guess something must've gotten corrupted along the way. Weird thing I noticed was that in the \appdata folder where you see all your previous Live installations, I also had a folder for 9.7.4 -even though I never installed it. Maybe that's why deleting the undo and preference.cfg files didn't work.

    In any case, back to topic, both Kontakt 5.5.2 and Kontakt Portable 5.6.8 are running smoothly with Live 9.7.3 (64x).
     
  11. homer_simpson

    homer_simpson Member

    Joined:
    Jan 21, 2014
    Messages:
    130
    Likes Received:
    18
    Guys i need a little help :)

    I have installed portable version 5.6.6 with update to 5.6.8... all exe, dll etc files are copied and all works fine except of vst plugins....
    Standalone works gr8 with added libraries but i have a problem to run it as a plugin.... got this info.....

    [​IMG]

    any advices/help would be nice :) Unfortunatelly i dont know russian....
     
  12. Peter Krav

    Peter Krav Producer

    Joined:
    Jun 23, 2017
    Messages:
    169
    Likes Received:
    96
    Location:
    Завод Юпітер
    1 can't load "system" _before vst
    2 error Load file from "C:Program Files.......etc
    3 error (when) Execute WinApi code error2: the rest is unknown language (to me)
     
  13. homer_simpson

    homer_simpson Member

    Joined:
    Jan 21, 2014
    Messages:
    130
    Likes Received:
    18
    the rest is in polish :)

    thx for the info.... now i have to find what i did wrong :D
     
  14. Vega

    Vega Newbie

    Joined:
    Oct 11, 2016
    Messages:
    40
    Likes Received:
    0
    I had the same issue but if you start your DAW as Administrator, everything works great!

    The only thing I am puzzled about is that this portable 5.6.6 version won't install in 'Program Files' so I installed it in a different location on my C:/ drive and things are fine...
     
  15. Spiritos

    Spiritos Noisemaker

    Joined:
    May 4, 2013
    Messages:
    106
    Likes Received:
    5
    Location:
    Amsterdam
    The very idea of "portable" is it won't install so not showing in "Program Files" is perfectly normal :)
     
  16. uhub

    uhub Ultrasonic

    Joined:
    Dec 9, 2016
    Messages:
    72
    Likes Received:
    20
    Run the Daw as Admin :winker::bleh:
     
  17. Vega

    Vega Newbie

    Joined:
    Oct 11, 2016
    Messages:
    40
    Likes Received:
    0
    Hi Guys,

    I am currently using Windows 7 Pro 64 bit with Cubase 7.
    Kontakt 5.6.8 Portable works great in stand alone mode and also inside Cubase 7, but for some strange reason that I cannot figure out, when I want to have my old installed Kontakt 5.5.0 and K 5.6.8 Portable to both coexist inside Cubase, only the old 5.5.0 is available.

    As a test I have tried removing the old 5.5.0 .dll files and at that point Kontakt 5.6.8 Portable appears inside Cubase 7. I wonder if there is a way to have both 5.5.0 and 5.6.8 inside Cubase at the same time. I think there may be something scripted inside the 5.6.8 .dll files (or the little Kontakt 5 file that is present with the three .dll files) that prevents the portable version to coexist with the older version.

    I have tried to use Reaper instead of Cubase 7 and the interesting thing is that in Reaper, both K 5.5.0 and the K 5.6.8 Portable version are available and recognized...

    I am wondering if anyone has managed to have two versions of Kontakt coexist inside Cubase Pro 9, maybe Cubase 7 plugins manager is too old and this is why I get this strange situation.

    Thanks a lot in advance for any feedback and/or help in trying to resolve this slight glitch;-)
     
  18. Spiritos

    Spiritos Noisemaker

    Joined:
    May 4, 2013
    Messages:
    106
    Likes Received:
    5
    Location:
    Amsterdam
    @Vega : Did you install the portable version or just placed it somewhere on your HDD/SDD? (both are a valid option to make them work). The portable version should in any case NOT be placed in your C:\Program Files directory as this messed things up for me (in Live). I didn't test it in Cubase though (I have the AI LE version) but my guess is it's best to put the portable version on a non-OS drive then add the location seperately in Cubase.
     
  19. Vega

    Vega Newbie

    Joined:
    Oct 11, 2016
    Messages:
    40
    Likes Received:
    0
    Hi Spiritos,

    Thanks for your kind reply!

    Initially I did install the 5.6.6 and respective 5.6.8 update in C:/Program Files but then I got an error presumably saying that the operation was not permitted... then I simply move it in My Documents folder where I have created a dedicated VSTPlugins folder where I keep all my VST plugins to also work with other stand alone VST Hosts like Cantabile.
    Perhaps this is the problem, maybe I should have, as you suggested, the Kontakt 5.6.8 Portable version in a separate drive, completely separate from the other Kontakt 5.5.0 version and then add that directory path to Cubase and see if it makes any difference.

    As I have mentioned before, the interesting thing is that both Cantabile and Reaper read both 5.5.0 and 5.6.8 .dll files without any issue and I can use them together in the same session, but Cubase doesn't like that for some strange reasons.

    I will do as you suggested and report back with my findings;-)
     
  20. Spiritos

    Spiritos Noisemaker

    Joined:
    May 4, 2013
    Messages:
    106
    Likes Received:
    5
    Location:
    Amsterdam
    It's worth the effort for sure. I initially had similar problems until I read somewhere to put the portable version on a non-OS disk and it solved mine. Each DAW works different indeed with paths. For instance I have a dedicated Ableton folder where I put all the shortcuts to VST's since Live only allows for one VST-folder.

    Also make sure you check registry leftovers. Hope you sort it out!
     
  21. Vega

    Vega Newbie

    Joined:
    Oct 11, 2016
    Messages:
    40
    Likes Received:
    0
    I did several tests this morning and I can report that here at my end, installing Kontakt 5.6.6 Portable on a separate disk doesn't make any difference with my Cubase 7 issue. As long as the 5.5.0 .dll files are scanned, they supersede the 5.6.6 Portable .dll files and I have found this same issue also in Sibelius 7.5. There seem to be a situation that in certain software's the two Kontakt versions cannot coexist together...

    My last test is to try with Cubase Pro 9 to see if I can make things work otherwise I will have to choose one version or the other. I do like this portable Kontakt 5.6.6 solution over the other 5.6.6 solution where it is required to copy files all over the place, which I find too complicated.
     
Loading...
Similar Threads - Kontakt portable Forum Date
Kontakt 6 portable ? Kontakt Oct 6, 2018
Tubular Bells works in Kontakt PORTABLE (but not in the other) WHY? Kontakt Sep 22, 2018
Getting eDNA Earth to work in Kontakt Portable Software Sep 11, 2018
What is the deal with portable Kontakts? Kontakt Sep 4, 2018
Kontakt Portable 5.8 - No Piano Software Sep 2, 2018
Loading...