edna + kontakt 6

Discussion in 'Kontakt' started by vector99, Nov 14, 2018.

Tags:
  1. vector99

    vector99 Kapellmeister

    Joined:
    Oct 23, 2015
    Messages:
    183
    Likes Received:
    70
    does anyone know why edna earth doesnt work with kontakt 6 ?

     
  2.  
  3. Nana Banana

    Nana Banana Audiosexual

    Joined:
    Oct 3, 2016
    Messages:
    514
    Likes Received:
    549
    Location:
    The 3rd Dimension
    That happened to me also. K6 couldn't find "Earth.nicnt". I had originally used "Spitfire Earth.nicnt" as the nicnt file, but after that error, I renamed it to Earth.nicnt, and it started working again.
     
  4. JR Studioz

    JR Studioz Guest

    i think you need to add the library to the kontakt browser list.
     
  5. Andreas

    Andreas Newbie

    Joined:
    Dec 20, 2015
    Messages:
    8
    Likes Received:
    2
    Same here with Kontakt 6 Portable. eDNA did work but I switched to Kontakt Portable some months ago and did not check eDNA, but after I read this post, I did and found out it is not working anymore.
    Error massage when trying to load an instrument:
    "This instrument belongs to a library that is currently not installed"

    Of course it is installed and shows up just normal in the library tab, but...
     
  6. jazzzz

    jazzzz Kapellmeister

    Joined:
    Mar 13, 2018
    Messages:
    259
    Likes Received:
    74
    Best Answer
    It usually happens when the SNPID number in the .nicnt file is modified, not the original one. In some libraries there are other codes regarding to the factory-given SNPID code, so you shouldn't change it.
    I don't have this library to check the .nicnt file that it was released with, and can't test it.
    But there was an emulator version of 5.7.3 that came with the vast majority of known libraries preadded in NativeAccess file. Normally this file doesn't contain the libraries' info because they are in separate .xml file but that version of Kontakt had it this way (and that was also the reason why people shouldn't update from that version to the newer symlink versions).

    Anyway, first check the content of the .nicnt file, if the SNPID number matches with the one in the .xml file created with the name of the library in Service Center folder. Then check in that .xml file if you see similarities with the text (I'm copying here) from that NativeAccess.xml file of the emulator version:

    <Product version="2">
    <UPID>4648f8ea-76ed-4b91-9854-0459c8b429e1</UPID>
    <Name>Earth</Name>
    <Type>Content</Type>
    <RegKey>Earth</RegKey>
    <SNPID>519</SNPID>
    <AuthSystem>RAS2</AuthSystem>
    <Relevance>
    <Application nativeContent="true">Kontakt</Application>
    </Relevance>
    <PoweredBy>Kontakt</PoweredBy>
    <Visibility>0x01</Visibility>
    <ProductSpecific>
    <HU>A3C6AF392BC42283713EE4E29818B001</HU>
    <JDX>EE22CB97130A83F10E3C8D345BEC6A9C1C384FF969F281EE500013D26B185397</JDX>
    <Visibility type="Number">3</Visibility>
    </ProductSpecific>
    <Company>Spitfire Audio</Company>
    <NKSEnabled>false</NKSEnabled>
    <Icon>spitfire</Icon>
    </Product>

    If everything seems normal, there is one more option to try. Remove that library from Kontakt. Close Kontakt. Removing the {library's_name}.xml, and from registry (in case of windows, in mac it would be a .plist file in Library/Preferences).
    Then try adding it again in Kontakt.

    Depending on your Kontakt version and release, it can happen that that version also have the NativeAccess.xml preloaded with all of the known libraries data and it may differ from the .nicnt file you have for this library.
     
    • Like Like x 2
    • Winner Winner x 2
    • List
  7. vector99

    vector99 Kapellmeister

    Joined:
    Oct 23, 2015
    Messages:
    183
    Likes Received:
    70
    ok thnx guys
     
  8. jazzzz

    jazzzz Kapellmeister

    Joined:
    Mar 13, 2018
    Messages:
    259
    Likes Received:
    74
    Please let us know which was the problem in your case. Thanks
     
  9. Andreas

    Andreas Newbie

    Joined:
    Dec 20, 2015
    Messages:
    8
    Likes Received:
    2
    Hey Jazzzz !

    Thank you very much for the tips. eDNA is working now! :wink:

    First of all, I use the portable version of Kontakt 6.0.2 R050.
    I removed eDNA from Kontakt with the Library Manager.

    Searched in my registry, but I think because I use the portable version there was nothing found to be removed.
    I checked the .nicnt File and i said exactly what you posted here.

    My NativeAccess file also did not have anything inside with regard to eDNA, BUT
    in c:\Program Files\Kontakt6Portable\UserData\Service Center\ I found a file named LibraryHints.xml.
    After adding eDNA to Kontakt again, I found this:

    <Library>
    <Name>Spitfire eDNA Earth</Name>
    <Company>(Self-made)</Company>
    <SNPID>A0C</SNPID>
    <Relevance>
    <Application nativeContent="true">Kontakt</Application>
    </Relevance>
    <RegKey>5F752C43-C7B9-48B6-AFFB-E5527011ADA5</RegKey>
    </Library>

    Then I changed the <SNPID from A0C to 519 in LibraryHints.xml and all of a sudden - the library worked ;)

    So the SNPID code was the problem, as you said. Thanks man!

    Hope others can make eDNA workable again too.
     
    • Interesting Interesting x 1
    • List
  10. homer_simpson

    homer_simpson Kapellmeister

    Joined:
    Jan 21, 2014
    Messages:
    205
    Likes Received:
    51
    Location:
    Poland
    works fine here..... I have OLD version.... still w8ting for Santa for little update ;p
     

    Attached Files:

    • edna.png
      edna.png
      File size:
      537.7 KB
      Views:
      41
  11. juxtaphon

    juxtaphon Noisemaker

    Joined:
    Dec 30, 2016
    Messages:
    6
    Likes Received:
    3
    awesome, so thankful for this info guys! finally got this great lib to work in my portable kontakt 5.8. i had to delete the xml code from within the earth.nicnt that came originally with the earth library - replacing that with this xml from jazzz's comment above:

    <Product version="2">
    <UPID>4648f8ea-76ed-4b91-9854-0459c8b429e1</UPID>
    <Name>Earth</Name>
    <Type>Content</Type>
    <RegKey>Earth</RegKey>
    <SNPID>519</SNPID>
    <AuthSystem>RAS2</AuthSystem>
    <Relevance>
    <Application nativeContent="true">Kontakt</Application>
    </Relevance>
    <PoweredBy>Kontakt</PoweredBy>
    <Visibility>0x01</Visibility>
    <ProductSpecific>
    <HU>A3C6AF392BC42283713EE4E29818B001</HU>
    <JDX>EE22CB97130A83F10E3C8D345BEC6A9C1C384FF969F281EE500013D26B185397</JDX>
    <Visibility type="Number">3</Visibility>
    </ProductSpecific>
    <Company>Spitfire Audio</Company>
    <NKSEnabled>false</NKSEnabled>
    <Icon>spitfire</Icon>
    </Product>

    then edit the LibraryHints.xml file inside my portable kontakt folder and manually add in the xml below and when i went to add the library and load some instruments, everything magically worked. no more annoying errors in kontakt; i can use this amazing library again; cheers!:

    <Library>
    <Name>Spitfire eDNA Earth</Name>
    <Company>(Self-made)</Company>
    <SNPID>519</SNPID>
    <Relevance>
    <Application nativeContent="true">Kontakt</Application>
    </Relevance>
    <RegKey>5F752C43-C7B9-48B6-AFFB-E5527011ADA5</RegKey>
    </Library>


    note - i did also delete any entries for edna earth in my registry(on win7) but i'm not sure if that actually did anything since kontakt portable works inside it's own sandbox environment.
     
    Last edited: May 29, 2019
  12. jazzzz

    jazzzz Kapellmeister

    Joined:
    Mar 13, 2018
    Messages:
    259
    Likes Received:
    74
    WTF is this?
    RegKey should be the name of the library. And this code doesn't even match with any of the codes in the .xml
    Where did you get this from?


    Edit:
    I realized that it was in Andreas' post. Hmm, very strange, why is it in the LibraryHints.xml this way.
     
    Last edited: May 30, 2019
  13. jonathanrodhes

    jonathanrodhes Member

    Joined:
    Apr 17, 2015
    Messages:
    65
    Likes Received:
    19
    i didn't know that edna is involved with this stuff :woot:

     
    Last edited: May 30, 2019
  14. luvsky

    luvsky Newbie

    Joined:
    Jun 4, 2018
    Messages:
    1
    Likes Received:
    1
    Quick way to solve this problem without modify .nicnt file:
    After you added eDNA to library it does not show up because for some reason the name that register in Registry (Spitfire Earth) and NativeAccess.xml (Earth) is not match, so to solve this is just change the registry name from "Spitfire Earth"to "Earth" .
    [Computer/Software/Native Instrument/Spitfire Earth] (Right click on this folder and rename it to "Earth) .

    Hope this help.
     
  15. EkniqueSounds

    EkniqueSounds Newbie

    Joined:
    Nov 14, 2019
    Messages:
    1
    Likes Received:
    0
    Was wondering if someone could help me. My eDNA doesnt work because I have either corrupted or lost a file called Spitfire Earth_info.nkx

    Hope someone can share this file to me.

    Regards,
    Daniel
    [email protected]
     

    Attached Files:

Loading...
Similar Threads - edna kontakt Forum Date
Getting eDNA Earth to work in Kontakt Portable Software Sep 11, 2018
Spitfire eDNA wont work in kontakt Kontakt Aug 3, 2018
save changes to instrument Kontakt eDNA Kontakt Sep 28, 2014
WaveDNA Liquid Music Software Apr 7, 2017
WaveDNA release Liquid Music for Live Software News Sep 24, 2015
Loading...