East West libraries in demo mode in Kontakt 6.6.1

Discussion in 'Kontakt' started by michaelv, Sep 22, 2021.

  1. michaelv

    michaelv Newbie

    Joined:
    Dec 30, 2013
    Messages:
    58
    Likes Received:
    2
    Well, here's a first. I recently installed a non legit version of K 6.6.1. Initially, all seems fine, but then I noticed all my East West libraries (legit) were in demo mode, and eventually I was asked to activate them. Well, they ARE activated. You can see the details from my screenshots.If I click on the "activate library" I'm taken to Native Access and as you will note, the library/s in question are already activated.

    Luckily, I also have Kontakt 5.8.1 installed, as a contingency. The EW stuff works fine in that. To be clear, all my other libraries (legit and non-legit) are working in 6.6.1: it's only the following...

    All East West:
    SOStrings Pro XP
    SOWoodwinds Pro XP
    SOBrass Pro XP
    SOPercussion Pro XP
    Stormdrum 1
    Symphonic Choirs

    I've tried trashing both forms of plist for each library to no avail. OK, at least I can get them to work in 5, but it's puzzling, and I would prefer to be using 6.6.1

    Any thoughts/advice will be appreciated.

    Screen Shot 2021-09-22 at 9.45.41 AM.png Screen Shot 2021-09-22 at 9.47.25 AM.png Screen Shot 2021-09-22 at 10.04.14 AM.png
     
    Last edited: Sep 22, 2021
    • Interesting Interesting x 1
    • List
  2.  
  3. lasteno

    lasteno Platinum Record

    Joined:
    Apr 14, 2013
    Messages:
    390
    Likes Received:
    163
    same here on mac os catalina ... same version =(
    upload_2021-9-22_10-44-2.jpeg
     
  4. michaelv

    michaelv Newbie

    Joined:
    Dec 30, 2013
    Messages:
    58
    Likes Received:
    2
    We are not alone, then. I'm on Mojave, BTW. That is weird.At least we can get them to work in K5. Actually, I was previously on 6.5.3 and it was fine, but I want to move to the latest version whenever possible, or reasonable.

    Thank you for sharing.
     
  5. visitor

    visitor Ultrasonic

    Joined:
    Apr 7, 2021
    Messages:
    76
    Likes Received:
    24
    East West is so weird. I was legit subscribed to them because I was hyped for Opus but, aside from their super slow method of downloading all the libraries, they kept giving me "missing samples" even though I spent hours trying to download everything. They also say I can't leave the subscription plan for a whole year, so it feels like I'm paying for stuff I'm not really using right now.

    good libraries, but questionable choices
     
  6. Xupito

    Xupito Audiosexual

    Joined:
    Jan 21, 2012
    Messages:
    5,415
    Likes Received:
    2,943
    Location:
    Europe
    This is a known problem for old/homemade libraries with v6.6.1 R2R. Haven't tried yet but there's people here who knows this stuff, @bobdule being one the best.
     
  7. michaelv

    michaelv Newbie

    Joined:
    Dec 30, 2013
    Messages:
    58
    Likes Received:
    2
    As I write, my only known problem company is East West. Obviously, their newer products are on their own players, which I have, but I still use the earlier stuff, because much of it is damn good. I think it's sensible to keep an earlier version of Kontakt available for any such issues.I expect this to be rectified in later updates.

    Thanks for the replies/info, thus far.
     
  8. Smoove Grooves

    Smoove Grooves Audiosexual

    Joined:
    Jan 26, 2019
    Messages:
    5,231
    Likes Received:
    1,958
    I don't think it's that...
    Because they had their own type of installer way back I think.
    So something has changed in one of the K6 updates I guess.
    @bobdule?
     
  9. bobdule

    bobdule Platinum Record

    Joined:
    Dec 28, 2014
    Messages:
    316
    Likes Received:
    162
    update EWQL nicnt's xml part to ras3 as they are writen in NativeAccess.xml
     
    • Agree Agree x 1
    • Winner Winner x 1
    • Interesting Interesting x 1
    • Useful Useful x 1
    • List
  10. odod

    odod Platinum Record

    Joined:
    Jun 5, 2011
    Messages:
    602
    Likes Received:
    259
    new OPUS software will make your life easier, it can download just the missing thing .. however it is still buggy with the EW Choir Platinum ..
     
  11. darknight

    darknight Ultrasonic

    Joined:
    Apr 8, 2013
    Messages:
    72
    Likes Received:
    21
    Same bug here. Hard to resolve.
     
  12. michaelv

    michaelv Newbie

    Joined:
    Dec 30, 2013
    Messages:
    58
    Likes Received:
    2
    Thank you for that. I'm certain you know your stuff; unfortunately, I haven't clue what you're talking about. I have no idea what an ras3 might be.

    But, for your reference, I took a look in the Service Centre folder and there are no XML files to be found for the East West libraries.

    I'm going to do some research into this ras3 thing....
     
    Last edited: Sep 23, 2021
  13. bobdule

    bobdule Platinum Record

    Joined:
    Dec 28, 2014
    Messages:
    316
    Likes Received:
    162
    open C:\Program Files\Common Files\Native Instruments\Service Center/NativeAccess.xml with a text editor
    this is the all products list.

    search Symphonic Choir inside

    <Product version="6">
    <UPID>def4e148-4338-47e7-86c0-fe84d751c80c</UPID>
    <Name>Symphonic Choirs</Name>
    <Type>Content</Type>
    <RegKey>Symphonic Choirs</RegKey>
    <SNPID>762</SNPID>
    <AuthSystem>RAS3</AuthSystem>
    <Relevance>
    <Application minVersion="5.6.8" nativeContent="true">Kontakt</Application>
    </Relevance>
    <ProductSpecific>
    <Visibility type="Number">3</Visibility>
    </ProductSpecific>
    <Company>East West</Company>
    <NKSEnabled>true</NKSEnabled>
    <Icon>eastwest</Icon>
    </Product>

    replace the xml data of nicnt by these one's AuthSystem>RAS3 & Product version="6"
    kontakt will see it as the last version using jwt license, the ras3 auth system mode.
     
    • Like Like x 3
    • Winner Winner x 2
    • Useful Useful x 1
    • List
  14. Smoove Grooves

    Smoove Grooves Audiosexual

    Joined:
    Jan 26, 2019
    Messages:
    5,231
    Likes Received:
    1,958
    :)...but then I noticed you have a misunderstanding!:
    All libraries are just shared.
    There is no cracking involved.
    Using shared libraries involves having a cracked version of Kontakt.

    Do what @bobdule said.
    Thank you for coming, bob.
     
  15. BaSsDuDe

    BaSsDuDe Audiosexual

    Joined:
    Mar 3, 2021
    Messages:
    964
    Likes Received:
    685
    Bob and SG are absolutely correct. Also consider as both have said in the past, that it is possible that if it is an older library, which it looks like, that it was pre-nicnt and will still scan and add without one. So if their suggestions do not work which they should, move the nicnt file you created somewhere else and try to add the library again. Also, check the snpid number in your nicnt matches the one in the NativeAccess.xml, as suggested because that has also been known to cause the same problem and also not display the library at all sometimes.
     
  16. michaelv

    michaelv Newbie

    Joined:
    Dec 30, 2013
    Messages:
    58
    Likes Received:
    2

    Lol, I have no misunderstanding, Mr. Smoove ;-). I know that libraries are not "cracked", and I never used that word. I write non-legit, or legit to clarify certain....states of ownership. Each to their own euphemism, I guess. As for Mr. Bob, what he kindly supplied was for Windows. I'm a Mac user. But in the end I did find that Mac equivalent file. However, as I said, none of the East West libraries show up in the Service Centre, so that means they are not present in the product list.

    As I also said, they were fine in 6.5.3. Only in 6.6.1 have they disappeared, so it appears to me that it's not strictly a V.6 Kontakt issue. By that I mean (as Smoove Grooves wrote) it's occurred, somehow, in an update.

    Many thanks to all for contributing. This is a great place to learn.
     
    Last edited: Sep 24, 2021
  17. Smoove Grooves

    Smoove Grooves Audiosexual

    Joined:
    Jan 26, 2019
    Messages:
    5,231
    Likes Received:
    1,958
    Okay, but paid for or not has no relevance here.
    Ergo clarifying "states of ownership" is also not relevant.
    'I' said "cracked" yes; you didn't.
    As I read! And yes, I have already heard problems like this on mac with this new version.
    That's why I always hang back. Work too important.

    Just to recap; please make sure you are not trying to add these EW libraries with a bespoke .nicnt.
    If they have .nkc and .nkx, they acted like the later .nicnt.

    Good luck.
    Please come back and let us know if you ever get sorted.
    Problems of this nature for mac users needs to be kept on top of.
     
  18. ted2020

    ted2020 Newbie

    Joined:
    Feb 27, 2018
    Messages:
    85
    Likes Received:
    1
    Just seen this thread and posted the same kinda issue..

    Have Kontakt 5.6.0 for adding libraries, and Kontakt 6.3.2 (Mac User Here)

    All was fine, but had to update to 6.6.1 to use some latest NI Libraries. Update all fine and working.
    However some East West and older libraries now no longer show in the tabs, but when loading K5 they are there?

    Is it easier to use K5 and K6.6.1 together or is there a workaround to get these all in the latest K6.6.1 Kontakt working ok?
     
  19. Rondo

    Rondo Newbie

    Joined:
    Jun 26, 2019
    Messages:
    2
    Likes Received:
    0

    I originally had a custom nicnt I made for EWQLSO Gold Ed which I got rid of from your suggestion here, but now when I add the library using the .nks files, there's no .xml file created for the library. additionally, the library isn't showing in 6.6.1. Should I create one from scratch using the service center xml?
     
  20. Xupito

    Xupito Audiosexual

    Joined:
    Jan 21, 2012
    Messages:
    5,415
    Likes Received:
    2,943
    Location:
    Europe
    Yep. Look their data in SCenter xml and create a suitable nicnt just like Bobdule said.
     
  21. Rondo

    Rondo Newbie

    Joined:
    Jun 26, 2019
    Messages:
    2
    Likes Received:
    0
    Ok did everything by the book here, copied the code from native access.xml to the new xml file. Still no luck. I'm on a MacBook Pro 14" 2021 running OSX 12.0.1 using Kontakt 6.6.1. Everything works fine in Kontakt 5.6.0, but in 6.6.1 it's not showing the library and loads instruments in demo mode. Any more ideas? Posting the .xml code below:

    <?xml version="1.0" encoding="UTF-8" standalone="no" ?>
    <ProductHints spec="1.0.16">

    <Product version="6">
    <UPID>0970f3df-ed14-4b3c-b0dd-f4e3f6ce2803</UPID>
    <Name>EWQLSO Gold Ed</Name>
    <Type>Content</Type>
    <RegKey>EWQLSO Gold Ed</RegKey>
    <SNPID>723</SNPID>
    <AuthSystem>RAS3</AuthSystem>
    <Relevance>
    <Application minVersion="5.6.8" nativeContent="true">Kontakt</Application>
    </Relevance>
    <ProductSpecific>
    <Visibility type="Number">3</Visibility>
    </ProductSpecific>
    <Company>East West</Company>
    <NKSEnabled>true</NKSEnabled>
    <Icon>eastwest</Icon>
    </Product>

    </ProductHints>
     
Loading...
Loading...