Arturia Keylab 49, dead keys - is there a fix?

Discussion in 'Instruments' started by FWRG, Mar 25, 2021.

  1. FWRG

    FWRG Noisemaker

    Joined:
    Mar 21, 2021
    Messages:
    13
    Likes Received:
    5
    Hey folks!
    So i have the aforementioned midi controller (which is a friend's, ouch!) where one note was not working - at all. At first it wasnt working sometimes and then proceeded to not work at all.
    After opening it and clearing it from dust, i have two whole octaves that dont work.
    I have all drivers installed plus the firmware from Arturia but to no avail, is there a fix around it or should i paint it blue and pollute the sea with it?

     
  2. Smoove Grooves

    Smoove Grooves Audiosexual

    Joined:
    Jan 26, 2019
    Messages:
    4,500
    Likes Received:
    1,648
    Oh dear. Either your "cleaning" of your once "friend's" contacts was too vigourous and you damaged the, uh, bits (too technical!) or you have dislodged the connector for a whole set...wait...you've only got 4 octaves anyway.
    If it's just the latter, you may still have that person as a friend.
    When they 'go', they go exactly as you describe: a whole octave or more at a time.
    You may have scraped off the coating on the contacts.
    In which case you'll possibly pay as much as the thing itself to source the parts and get a proper technician to repair it.
    When I mentioned contact cleaning in your other post about this, I was not suggesting you should attempt it yourself!
    This should have been obvious when you realised you don't know what you are doing! lol.
    Plus, the modern stuff is made as hard as possible to be self-serviced by a non-experienced person.
    Such that you will damage it irreparably.
    80s stuff was easier. 90s stuff harder. This is much newer.
    But either way, one has to know what one is doing.
     
  3. spncart

    spncart Ultrasonic

    Joined:
    Dec 13, 2020
    Messages:
    104
    Likes Received:
    20
    Arturia is known for having a non-existent customer service, good luck.
     
    • Dislike Dislike x 1
    • Interesting Interesting x 1
    • List
  4. ArticStorm

    ArticStorm Moderator

    Joined:
    Jun 7, 2011
    Messages:
    4,689
    Likes Received:
    1,719
    Location:
    AudioSexPro
    thank god i didnt decide for this one and i read across the internet that a lot of people have problems with broken keys on the keylab and this very quickly after not really much usage.

    you could still try to mail Arturia for support?
     
  5. Cyril@Arturia

    [email protected] Noisemaker

    Joined:
    Mar 26, 2021
    Messages:
    1
    Likes Received:
    3
    Hi,
    Cyril from Arturia here. Please contact our support team through this link :
    https://www.arturia.com/support/askforhelp/issues

    They do their best to answer quickly but If you have some trouble to get in touch with them (which should not happen), feel free to send me a PM.

    Best
     
    • Like Like x 3
    • Interesting Interesting x 1
    • Love it! Love it! x 1
    • List
  6. aymat

    aymat Audiosexual

    Joined:
    Dec 21, 2015
    Messages:
    609
    Likes Received:
    642
    Arturia controllers have a tendency to develop dead keys over a shot time. Ive had to do this before with my Keystep but just open it up aand clean the contacts and underneath the conductive rubber strips with rubbing alcohol using a qtip. You should be fine.
     
  7. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    4,872
    Likes Received:
    4,079
    Location:
    NOYMFB
    Best Answer
    @FWRG don't freak out. It is an easy and inexpensive fix. I hope you did not use contact cleaner because that will damage the rubber contact strips.
    Before opening it do a factory reset and see if it solves the problem. If reset does not work try flashing the firmware again. If not solve go to the steps below.
    Re-open it. You only have on ribbon going from main control PCB to the keybed. Make sure that it is firmly placed and in the correct position. They are made to go in the right way but I have seen enough crazy shit with those. When you invert those you end up losing some octaves. Also make sure that the connectors on the right are properly plugged in. If that does not solve the problem go to next step.
    Second, remove keybed so you can get to the rubber contact strips. Take them all out, and using a pencil eraser clean each of the contact heads. Do it one at a time. Pass over each one several time until there is no trace on eraser. When putting them back make sure they are properly placed back where they belong. Good thing is that both, the 12 and 13 keys strips cost but $12. So if you need to replace them go to https://syntaur.com/Items.php?Item=4158.
     
    • Like Like x 4
    • Winner Winner x 1
    • List
  8. FWRG

    FWRG Noisemaker

    Joined:
    Mar 21, 2021
    Messages:
    13
    Likes Received:
    5
    Thank you guys for all the replies and the truble.
    Thing was a strip needed just a bit of a move to work.
     
  9. The Pirate

    The Pirate Audiosexual

    Joined:
    Dec 20, 2018
    Messages:
    4,872
    Likes Received:
    4,079
    Location:
    NOYMFB
    Glad my suggestion worked for you.:like:
     
  10. Zenarcist

    Zenarcist Audiosexual

    Joined:
    Jan 1, 2012
    Messages:
    2,708
    Likes Received:
    1,664
    Location:
    Planet Earth
Loading...
Similar Threads - Arturia Keylab dead Forum Date
What if I use an Arturia Keylab 61 as Midi controller ?? Computer Hardware Oct 18, 2013
Can I giveaway Arturia Analog Lab license key? Instruments Apr 10, 2021
Arturia Plug-Ins (Mac) Patch Issue Mac / Hackintosh Apr 5, 2021
Arturia Lab V5 Problem: Whenever I hit play instrument changes Software Mar 26, 2021
Arturia Filter M12 - Getting Creative with Filters Software Reviews and Tutorials Mar 20, 2021
Loading...