Adding Libraries in Kontakt (I know, I know...)

Discussion in 'Kontakt' started by emptybe33, Feb 13, 2019.

  1. emptybe33

    emptybe33 Newbie

    Joined:
    Feb 13, 2019
    Messages:
    7
    Likes Received:
    0
    Hello Peeps. I know it's been asked a millions times but I'm not a total noob. I've been adding libraries in Kontakt 5.6.8 just fine using a standalone 5.6.6 for ages but it seems to have stopped working on some other newer libraries. It either crashes and doesn't save changes or nothing happens at all.

    I've tried the SPID thing but the NICNT file still has it as '000' so no conflicts, just not working.

    Is there a workaround using Kontakt 6 or anything?

    Windows 7 64 bit
     
  2.  
  3. Smoove Grooves

    Smoove Grooves Audiosexual

    Joined:
    Jan 26, 2019
    Messages:
    3,558
    Likes Received:
    1,322
    Hi. You say "newer libraries". Is that not your answer, right there? Like, they are crashing Kontakt because they are for 5.7.1 or whatever?
    Either way, your answer IS here on the site, without a doubt. I just don't have the time to find it.
    Also, check the .xml file as well as the .nicnt.
     
    Last edited: Feb 15, 2019
  4. emptybe33

    emptybe33 Newbie

    Joined:
    Feb 13, 2019
    Messages:
    7
    Likes Received:
    0
    Thanks for the reply. Sorry, I'll clarify. Some brand new libraries are adding OK but some aren't.

    I checked the xml files on the ones that aren't and they too have SNPID as '000'.
     
  5. Smoove Grooves

    Smoove Grooves Audiosexual

    Joined:
    Jan 26, 2019
    Messages:
    3,558
    Likes Received:
    1,322
    No; I do get what you're saying. Just wanted you to check the minVersion requirements.

    Anyway; 000 is when Service Centre or Native Access hasn't been able to add it. Which is not what we want for the SNPID. That's the "conflict".

    I would usually just change the SNPID in the .xml to the SNPID that *should* be showing in the .nicnt. I've not needed to delete the .plist for this.
    But you say they are both 000...

    What libraries are you trying to add, please?

    edit: I have no idea what you mean when you say: "I've tried the SPID thing but the NICNT file still has it as '000' so no conflicts, just not working."
    Sounds like you did...'something'.
     
    Last edited: Feb 15, 2019
  6. emptybe33

    emptybe33 Newbie

    Joined:
    Feb 13, 2019
    Messages:
    7
    Likes Received:
    0
    Thanks again. My understanding was to check the SNPID value in both the ninct and xml file in the service centre to ensure they match and there are no conflicts with other libraries. I checked the value in both files for the libraries that I'm trying to add and in both they were '000'. I'm guessing that is because it never got added rather than a conflict. Am I correct there? If so, what next?
     
  7. Smoove Grooves

    Smoove Grooves Audiosexual

    Joined:
    Jan 26, 2019
    Messages:
    3,558
    Likes Received:
    1,322
    Which libraries?
     
  8. jazzzz

    jazzzz Producer

    Joined:
    Mar 13, 2018
    Messages:
    469
    Likes Received:
    144
    You really don't get it and are confusing every single detail.
    Nobody suggested to change anything in the .nicnt file, if the library came with it.
    If you read the instruction given on the latest Kontakt release page on sister site, you just have to follow those easy steps. Don't ever try to think aside from that, just follow it after reading it calmly until the end. Don't think or say "I know, I know" because you don't... Believe me.
    If you have the SNPID in the .nicnt file with 000, it means you (or someone else) have changed it after having misunderstood the steps.
    The three zeros in .xml file means it's not added correctly. PERIOD. You have to correct the code in that .xml file based on the code in the .nicnt file of the library.
     
  9. modelarmy

    modelarmy Ultrasonic

    Joined:
    Apr 13, 2016
    Messages:
    88
    Likes Received:
    33
    When you have installed a Library in Kontakt 5.6.0 there is a .xml file in N.I Service Center.
    Open the .nicnt file and you read in the textfile something like this <SNPID>09e</SNPID>
    The 09e is important it is the code for this !!! library. Open .xml file and changed it to <SNPID>09e</SNPID>.
    Now you can see your library in Kontakt 6.
    The .nicnt file and the .xml file must have the same code.
    Hope it helps.
     
  10. spyki2000

    spyki2000 Newbie

    Joined:
    Aug 5, 2013
    Messages:
    31
    Likes Received:
    1
    hello just a query as stable kontakt 6 is not yet out by R2R so how do you guys open these latest libraries in older kontakt ??
    i have 5.6 kontakt but when i try new library it says it need new version and its been a year since there is no stable kontakt update from R2R
    so am i missing out anything ??? hope to get a solution :) thanks
     
  11. Smoove Grooves

    Smoove Grooves Audiosexual

    Joined:
    Jan 26, 2019
    Messages:
    3,558
    Likes Received:
    1,322
  12. Smoove Grooves

    Smoove Grooves Audiosexual

    Joined:
    Jan 26, 2019
    Messages:
    3,558
    Likes Received:
    1,322
    @spyki2000 Okay, I could answer your:-
    ...but I shan't...because u would be offended.
    Why do u reckon it would be possible to open the "latest libraries in older kontakt" ?
     
  13. jazzzz

    jazzzz Producer

    Joined:
    Mar 13, 2018
    Messages:
    469
    Likes Received:
    144
    in Kontakt for Windows there are those Portable versions, the easiest way and stable.
    In Kontakt for Mac the latest versions (already 6) are also quite stable. I don't know why would anyone wait for a R2R release.
    As far as I remember, R2R release required a preloaded library-list and you couldn't add any library with home-made .nicnt
     
  14. grdh20

    grdh20 Platinum Record

    Joined:
    Jan 14, 2014
    Messages:
    558
    Likes Received:
    193
    For some reason on my mac 5.6.6 stopped working (just crashes) but all other 5.x and 6.x versions work fine. odd..
     
  15. emptybe33

    emptybe33 Newbie

    Joined:
    Feb 13, 2019
    Messages:
    7
    Likes Received:
    0
    OK thanks for the replies. In answer to them:
    - I'm trying to add Spitfire Symphonic Evolutions (legit) and Chris Hein String Ensembles (cracked) and am having the same issue with both. With Spitfire it's just doing nothing when I try to add before it eventually crashes, where as Chris Hein shows up as a library momentarily before Kontakt crashes and it's not there when I reopen. Weirdly I managed to add Spitfire LCO Textures (legit) just now which is brand new where as Symph Evo is >12 months old...
    - With regards to the SNPID thing, I haven't changed anything. I literally bought and downloaded Symph Evo from Spitfire and went to install - Kontakt 5.6.6 crashed and library not added. In looking for a solution I checked the SNPID value in the ninct file and found it to be '000'.

    So (again) what am I missing? Or is there a workable portable version of 5.7 or 6 that can still add libraries without the need for 5.6.6?
     
  16. jazzzz

    jazzzz Producer

    Joined:
    Mar 13, 2018
    Messages:
    469
    Likes Received:
    144
    I suggest you to use 5.6.0 because 5.6.6 tends to crash as hell and it screws even those added libraries' .xml and .plist files that you need to delete before you attempt to add the libraries again.
    If you have a legit version, try to redownload it or ask them to send you just the .nicnt file. Searching in publicly available code lists it seems the code of Spitfire Symphonic Strings Evolution is P13 so try to correct it in the .nicnt file and then add the library with v5.6.0 and then follow the steps of the SNPID workaround (substituting the zeros in the .xml file with this P13)
     
  17. noize2sound

    noize2sound Kapellmeister

    Joined:
    Mar 23, 2018
    Messages:
    164
    Likes Received:
    67
    Location:
    Spokane
    True ... use 5.6.0
     
  18. Smoove Grooves

    Smoove Grooves Audiosexual

    Joined:
    Jan 26, 2019
    Messages:
    3,558
    Likes Received:
    1,322
    Thanks @jazzzz : that's why I was asking for the libraries, so I could just give the SNPID's. Felt it was easier!

    There is no such thing as a cracked or legit library, so I suppose the OP means cracked & legit Kontakt...
     
  19. jazzzz

    jazzzz Producer

    Joined:
    Mar 13, 2018
    Messages:
    469
    Likes Received:
    144
    I think OP referred to the library being legit (purchased by him-/herself), not Kontakt.
     
  20. emptybe33

    emptybe33 Newbie

    Joined:
    Feb 13, 2019
    Messages:
    7
    Likes Received:
    0
    Yes, the Kontakt is cracked and one of the libraries I'm trying to add is legit. I tried 5.6.0 and tried changing the SNPID in the ninct to P13 but to no avail. I also re-downloaded the ninct from Spitfire and still the same issue - it goes to add the library then...nothing. With Chris Hein Ensembles it at least looks like it adds it and crashes but it isn't there when I relaunch Kontakt. Grrrr.
     
  21. spyki2000

    spyki2000 Newbie

    Joined:
    Aug 5, 2013
    Messages:
    31
    Likes Received:
    1

    well someone has mentioned it so was curious is it possible and so asking may be some has found a way or something nothing wrong in asking right ?
    please don't get offended by my queries.
    forums are ment for all to ask and know if they are missing out on something.
    people who would want to help will revert to that.
    thanks
    :)
     
Loading...
Similar Threads - Adding Libraries Kontakt Forum Date
What am i doing wrong...adding libraries with Kontakted Kontakt Dec 11, 2020
Adding Libraries to Kontakt 6 does not work Kontakt Sep 22, 2020
Need some help adding libraries in Kontakt Kontakt Jul 7, 2019
Newer cracked Kontakt not adding libraries on Mac Kontakt Jan 26, 2019
Problem adding libraries in Kontakt Kontakt Dec 3, 2018
Loading...