Active Members Only: All Mac related Problems with Kontakt

Discussion in 'Kontakt' started by Introninja, Jan 14, 2014.

  1. Harrison

    Harrison Ultrasonic

    Joined:
    Dec 21, 2016
    Messages:
    43
    Likes Received:
    21
    Hey buddy so I go it figured out. It's either the SPNID or NICNT file but I went on ahead and created a new one of both for my libraries that weren't showing in 5.6.8. Before I added them back to the 5.6.6 library I removed all related files to them in the service center and preferences folders, added them back into kontakt 5.6.6 then once they were added I opened kontakt 5.6.8 and they were all in there without issue.

    hope this helps


     
  2. mcrein

    mcrein Newbie

    Joined:
    Nov 15, 2015
    Messages:
    15
    Likes Received:
    1
    thanks harrison
    i'm not using 5.6.6 but 5.6.0..do you think that might make a difference? also what programs are you using to change the SPNID and the NICNT...please remember i am on a mac...

    i also have a couple of libraries that now say they need to be added to the library before using but when i try to add them, they say error writing files. could that be a permissions issue? one adds ok in 5.6.0 but always runs in demo mode in 5.6.8..again, not mission critical libraries but would be interesting understand why...

    thanks
    m
     
  3. Harrison

    Harrison Ultrasonic

    Joined:
    Dec 21, 2016
    Messages:
    43
    Likes Received:
    21
    Hey Buddy, I will PM you the details and stuff :)



     
  4. Harrison

    Harrison Ultrasonic

    Joined:
    Dec 21, 2016
    Messages:
    43
    Likes Received:
    21
    Has anyone had issues with some libraries where you added them into Kontakt, it will load the NKI for the player part, but the samples are in constant purge mode? I cannot seem to find a fix. Thanks.
     
  5. DK

    DK Member

    Joined:
    Jul 30, 2017
    Messages:
    81
    Likes Received:
    10
    .
     
    Last edited: Sep 1, 2017
  6. Dmtr

    Dmtr Newbie

    Joined:
    Aug 31, 2017
    Messages:
    2
    Likes Received:
    0
    Hi guys, um this is my first message on the forum. I'm a new user of Kontakt, (downloaded 5.6.6 version using ngroups a few days ago) and I tried to load the ni scarbee mark I library into it today. Unfortunately I had a message telling me the library was encrypted etc... I realized it was something that happened to a large part of k'd kontakt users. So I read the first message of this topic and tried to follow as close as possible all the instructions, but the message kept poping whenever I tried to load the library. Furthermore, the reason why this message is appearing is still vague to me, and I really don't know how to fix it. I saw on the library's download page comments complaining about that problem so maybe it is concerning the library itself, but I truly believe that it can be fixed.

    That's why I came here, I need wise advices from more experimented people and any help is welcome.
     
  7. St0rMl0rD

    St0rMl0rD Newbie

    Joined:
    Oct 2, 2016
    Messages:
    36
    Likes Received:
    2
    HOW TO USE A LEGIT (PURCHASED) LIBRARY IN AN UNLOCKED KONTAKT

    Disclaimer: This was tested on a Mac, but this solution could also work on Windows.

    I decided to write this tutorial after I’ve spent quite some time trying to get my legit library to coexist in peace with my other (unlocked) libraries. The specific library I have purchased requires Kontakt 5.6.8 or later, so that was one of the issues I had to overcome. I found a solution, that works.

    1. Download and NI Kontakt Free Player
    2. Download and install NI Access
    3. Register and add your legit library to Kontakt Free Player via NI Access
    4. Install NI Kontakt Full (unlocked) 5.6.5
    5. Use only the AU plugin (or VST if you’re on Windows) to use with your DAW - don’t overwrite the standalone Kontakt 5.6.5
    6. Use the Kontakt 5.6.5 standalone to add unlocked libraries (even if they require 5.6.8 - they’ll be added, they just won’t show up in the standalone app)
    7. Use Kontakt 5.6.8 plugin in your DAW to use your legit and unlocked libraries

    Hope this helps someone!
     
  8. beaucarty

    beaucarty Newbie

    Joined:
    Oct 19, 2011
    Messages:
    100
    Likes Received:
    0
    Location:
    Paris - France
    Hi guys, I have five or six Library collection like "Project Sam" or "Spitfire" working on Kontakt v.5.6.6 which don't appear on 5.6.8...
    I tied to remove all related files from Service Center and preferences but same problem. It' really boring to search one lib among
    externals drives and don't remember which one contain the lib I need...If somebody got the same problem and find a fix ...
    ThanX :wink:
    I checked something...when I click on the right of the lib in Kontakt to open remove and choose opening containing folder nothing happen and when I choose a registered lib it open the folder on
    the internal or external drive corresponding to the lib...Brainstorming!!!!
     
    Last edited: Sep 26, 2017
  9. Bunty_19

    Bunty_19 Member

    Joined:
    Oct 24, 2015
    Messages:
    85
    Likes Received:
    9
    Behold..... Kontakt updated to 5.7 to scare the shit even more..
     
  10. beaucarty

    beaucarty Newbie

    Joined:
    Oct 19, 2011
    Messages:
    100
    Likes Received:
    0
    Location:
    Paris - France
    Hi Harrison could you tell me in pm the way to create new SPNID and NICNT and which program I need on Mac.
    I have some libs missing on 5.6.8. Thanx for help ;-)
     
  11. signalflow

    signalflow Kapellmeister

    Joined:
    Jun 10, 2016
    Messages:
    315
    Likes Received:
    74
    Does anyone have a template blank nicnt file that have been used successfully on 5.6.8? Most of the ones I made on 5.6.6 aren't showing up on 5.6.8 and I would like to see if it's the nicnt blank I'm using or if it's the spnid I'm using. Thanks to anyone in advance.
     
  12. GreenStudios

    GreenStudios Newbie

    Joined:
    Nov 11, 2016
    Messages:
    3
    Likes Received:
    0
    Hi friends, i need help on this ... I have a MacPro 2008 and I have installed the following software from 0. Step 1: Captain 10.11.6. Step 2: LogicPro X 10.3.2 from Appstore. Step 3: Kontakt 5.6.6. Step 4: I open the logic and everything is correct with Kontakt AU. Step 5: I add a nicnt library, for example session horns pro2 (native), it is added and all ok. Step 6: I close the logic, and reopen the logic, I open the kontakt and the library is not added. Step 7: I have tried 10 more libraries and never left in the kontakt. Step 8: in 10 years with this has never happened to me, and I'm from OSXTiger. Can anybody help me? Note: I'm sorry my English is horrible Thank you very much.
     
  13. taskforce

    taskforce Audiosexual

    Joined:
    Jan 27, 2016
    Messages:
    1,022
    Likes Received:
    1,052
    Location:
    Studio 54
    If this can be of any help, use version 5.6.0. The one including 5.4 and the upgrade to 5.6. It will keep the libraries you add np (as long as they are supported by the version). Tried and tested in various Macbooks.
    If i can judge by the pc version i 've tried, once someone gets it reversed for mac correctly, mac users will enjoy a better interface all in all too. Adding all your libraries is a matter of a couple of clicks in v.5.7.1 :wink:
     
  14. Pollice verso

    Pollice verso Platinum Record

    Joined:
    Dec 5, 2015
    Messages:
    196
    Likes Received:
    158
    Hi. I'm having problems with two new kontakt libraries: fluid strikes and soundiron glich hero. When i add in 5.6.5 standalone don't show there and nothing in 5.6.8 in logic. I'll try some tricks readed here and nothing, the only: libraries appears in 5.6.8 at least when i change the spnid numbers but then disapears in standalone. Xd xd :(
    thanks in advance
    EDIT
    Solved. After many reads and tricks here, thanks guys!!!, the thing was this one:
    The only i did was change SPNID NUMBER generated in XML file when you import in 5.6 for the ORIGINAL´s SPNID NUMBER of the nicnt library, then the library appears in 5.6.8 and it works.
    :disco:
     
    Last edited: Dec 14, 2017
  15. jandypants

    jandypants Newbie

    Joined:
    Dec 15, 2017
    Messages:
    1
    Likes Received:
    1
    HEY THERE

    I was able run both 5.6.6 and 5.6.8 k'd in Logic audio units simultaneously!! But cannot get my puter back to that state...

    On a whim a simply put in the K'd 5.6.6 - renamed it to Kontakt 5.6.6 old.component.
    threw it into in the audio library/audio/plug ins/ components alongside the previoud 5.6.8 . They then were still listed as one kontakt plug in logic . But that plug in had two groups of output options:The top of the two "stereo" was 5.6.8 and the bottom "stereo" was 5.6.6
    Unfortunately I removed one of my libraries in the tab while using the 5.6.6 plug , then the computer thought for a bit and now logic only recognizes the 5.6.6 if both are installed. If I try to rescan the plugs - nothing changes. both plugs are now listed as 5.6.6 in the scan process. tried pretty much everything 9trash plist and caches... etc and can't get it back.

    However I can still run both simultaneously in stand alone no problem.


    Like most here I've been using Kontakt for years. Really disappointed that in 5.6.8 onward libraries now are missing in the libarary tab. I own everything legit (literally hundreds of libraries) and now a good half of them no longer show up in the library tab which is my preferred workflow. When it worked this made it possible to have a simple non install workaround.

    Any help would be greatly appreciated to get it back. I know know it would solve this problem for so many!!!
     
  16. black bounty

    black bounty Platinum Record

    Joined:
    Nov 8, 2015
    Messages:
    361
    Likes Received:
    165
    Location:
    paris
    EDIT :
    forget it, I've found the solution (thanks undirectly to @jayxflash lol )
    I've deleted to xml file of ark 3 in library / application support / native instruments / service center / ..

    complementary to the steps I've mentioned below, it may have fixed it.

    thx anyway.
    :bow:



    hi guys

    I've just had an issue : I'm on mac, 10.9.5,
    I'm (was) running two versions of kontakt, 5.6.6 as a standalone, and 5.6.8 as plugins (component) in my DAWS

    today, I've tried to add the latest ARK 3 to my libs via my standalone 5.6.6 ( I didn't noticed it requested kontakt 5.7.1 ) and I don't know if it's related or not, but the 5.6.6 crashed and won't open anymore since then, it crashes every time.

    the 5.6.8 I use with my DAWS is stil working well, I've tried to erase the .playlist in preferences, and after that the kontakt folder in library, but still 5.6.6 won't open.

    this solution has always been working well so far, any idea where this come from ?

    got this from the crash report ( i can give you the whole thing if you want, I'm no expert ) :

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x00000000000000cc

    any help would be appreciated,

    :mates:

    :bow:
     
    Last edited: Jan 25, 2018
  17. sisyphus

    sisyphus Platinum Record

    Joined:
    Apr 29, 2014
    Messages:
    762
    Likes Received:
    243
    wait, so you got it figured out?
     
  18. koschke

    koschke Noisemaker

    Joined:
    May 25, 2012
    Messages:
    88
    Likes Received:
    5
    black bounty i have the same problem after ark 3 Kontak 5.6.6 not working anymore do one of you have solution for this can't add any other
    libraries.:(
    Already tried batch mode and sudo terminal input but nothing helped...:( I am on high sierra
    Thanks in advance for your answers...:guru:
     
    Last edited: Jan 29, 2018
  19. black bounty

    black bounty Platinum Record

    Joined:
    Nov 8, 2015
    Messages:
    361
    Likes Received:
    165
    Location:
    paris
    yes, I've just let the message so if anyone having the same problem could try this for a solution


    go iether to your library, or to your hidden user library - try both even ( in 10.9.5 it's alt + go to in the finder menu, library will show up in the list - I don't know if it's the same in high sierra since they've changed things )

    - remove com.native instruments. kontakt 5.plist
    - go to application support, remove the kontakt 5 folder
    - go to application support / native instruments / service center .. => remove the Ark 3 xml file

    maybe do a new 5.6.6 install

    I have only the 5.6.6.app that I've renamed "kontakt 6" along with the 5.6.8, got the 5.6.8 as a component and all is working fine.

    I hope this help

    :bow:
     
  20. seriousofficial

    seriousofficial Kapellmeister

    Joined:
    Jan 18, 2014
    Messages:
    142
    Likes Received:
    67
    Location:
    LA
    I'd like to know what the answer is to this problem. I've read through pages of threads and performed all kinds of suggested remedies but the problem remains the same with Spitfire Percussion Redux and Chamber Strings....bugging me.
     
Loading...
Similar Threads - Active Members related Forum Date
(For active members only) Nuraphone hands-on review Soundgear Apr 3, 2018
Active members only - 3 MONTH uploaded coupon UL.to Coupons May 11, 2015
Active Members ONLY. Uploaded.to 48hrs Coupon UL.to Coupons Jan 7, 2015
Active Members Only: Kontakt Problems with Windows? Please Post Here!!! Kontakt Jan 23, 2014
Topo - Teatris Show 062,Active Brand 106,Mcast 115 DJ Mixsets Feb 25, 2019
Loading...